RPi Installworld failed

balanga

Daemon

Reaction score: 100
Messages: 2,413

After successfully building FreeBSD for RPi2 using Crochet, ./crochet.sh -c config.conf stops with:-
Code:
Installing ubldr in /root/crochet/work/_.mount.boot
Installing FreeBSD world at Thu Nov 9 09:59:59 GMT 2017
        Destination: /root/crochet/work/_.mount.freebsd
/root/crochet/work/_.mount.freebsd: write failed, filesystem is full
Installworld failed.
        Log: /root/crochet/work/_.installworld.armv6.log
I'm using a 4GB MicroSDHC card in a USB reader.

gpart show md0
Code:
=>   63  1953062  md0  MBR  (954M)
        63  1953062          - free - (954M)
Not sure how Installworld works in this situation... Should I expect crochet to format the card and install everything? The guide I'm using suggests (in step 4) that dd should be used, so should I use the FreeBSD-armv6******.img use that as the source for dd instead of everything being done automatically?
 
OP
OP
B

balanga

Daemon

Reaction score: 100
Messages: 2,413

It hadn't been set, but I've changed it to 3900mb and the script runs to completion.

Unfortunately the final img produced does not boot up after dding to my MicroSD card. I also have a USB-serial connector hooked up to the RPi2 and nothing gets displayed vi cu. The same card was able to boot up LibrELEC previously so I think the card is fine.
 

acheron

Well-Known Member

Reaction score: 186
Messages: 462

Do you have the hdmi video connected? What's the version of uboot?
 
OP
OP
B

balanga

Daemon

Reaction score: 100
Messages: 2,413

Do you have the hdmi video connected? What's the version of uboot?
Nothing is output to the monitor and no uboot appears via a serial console.

I will run through the whole process to make sure I've followed the instructions correctly
 

Phishfry

Son of Beastie

Reaction score: 1,155
Messages: 3,303

What about using the default board file instead.
./crochet.sh -b RaspberryPi2

What version of source are you using? -CURRENT has went through quite a bit of changes on Arm recently.
 
OP
OP
B

balanga

Daemon

Reaction score: 100
Messages: 2,413

I'm currently waiting for a repeat of buildworld to finish - seems to take quite a while...

I ran git clone https://github.com/freebsd/crochet.git so used whatever that pulled in.. I wouldn't know how to use -CURRENT.

Incidentally, I tried this command on one of my other systems and was presented with a 'Username/password' prompt - no idea why.
 

Phishfry

Son of Beastie

Reaction score: 1,155
Messages: 3,303

There is a newer revision of the RPi2 it uses 64bit Arm instructions so it won't work with FreeBSD RPi2 stuff(32-bit CPU).
https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=162139

It does not boot on FreeBSD RPi3 image (almost the same board minus BT) either. At least not the last time I tried.
The lights blink but no serial console or HDMI.

So don't waste you time any further. Check the silkscreen board revision printed on your board.
 
Top