RP3 Build Help

I am trying to get an RPie3 img built using Crochet, but when I boot the image I only get the HDMI test screen and a solid red light. I do not have a USB serial cable, but I can acquire one if necessary.

I am using the current version of Crochet as of today with the /base/head version of FreeBSD source. I had to comment out the line
Code:
cp ${UBOOT_PATH}/armstub8.bin .
in /board/RasberryPi3/setup.sh as the build script could not find the file. I looked up that bin file and found that it is supposedly no longer necessary. I have attached my config file in case there is some issue there. I'm using the standard build command sh crochet.sh -c RP3.sh

Thanks for the help!
 

Attachments

  • RP3.txt
    12.4 KB · Views: 403
I changed everything back, and discovered that my u-boot-rpi3 was not up to date which is why that file was missing. Unfortunately I am still not getting anything other than the test screen on the HDMI. I'm going to try a different OS to make sure it isn't my hardware.

Update, Raspbian booted just fine. So I'm not really sure what is going on.
 
Ok, so then maybe it is booting just fine. I haven't ever had the NIC come up though so maybe I'm not waiting long enough, and it's probably not configured for DHCP then I would assume. Looks like I'm off to order a serial cable then. Thanks guys!
 
My serial cable came in today, and I am still not getting anything. I attached the cable, installed the drivers and used Putty on my windows machine to try and establish a connection. I tried with and without adding enable_uart=1 to my config.txt file. It appears to be hanging on boot from what I can tell. I don't understand what I am missing.

Update: I downloaded an iso from raspbsd.org that boots and runs fine. No idea what was wrong with my build, but I'm up and running.
 
Back
Top