Router cascade?

dewarrn1

New Member

Reaction score: 3
Messages: 19

Hi folks,

I just switched ISPs, and my new DSL modem has a built-in router. Previously, I'd been using my FreeBSD box as a router hooked up to a single-purpose cable modem, and I liked the way it worked. Now, however, the new router and my FreeBSD router aren't playing nice. Ideally, I'd like a solution that makes the DSL modem (D-Link 2540B) as dumb as possible, leaving all the work of DHCP, routing, etc., to the FreeBSD box. Anyone have any ideas or experience with this?

If not, I'd be willing to live with the current layout except for one problem. My network topology is as follows:
  • DSL modem connected to ISP
  • Integrated router connected to modem (with DHCP, DNS, etc.)
  • FreeBSD box connected to a LAN port on the modem/router running DHCP for two inward-facing networks
  • Wired network
  • Wireless network
Each network has a separate address space in the 192 range, and aside from the annoyance of having the extra LAN hop, there's only one problem with the current setup. Although computers connected to every other portion of the network get reliable DNS lookups, the FreeBSD box does not. What am I missing? Thanks in advance!
 

da1

Aspiring Daemon

Reaction score: 96
Messages: 881

dewarrn1 said:
Ideally, I'd like a solution that makes the DSL modem (D-Link 2540B) as dumb as possible, leaving all the work of DHCP, routing, etc., to the FreeBSD box.

The router should have an option to disable some services like dhcp, dns, etc. look them up in the web-interface.

Although computers connected to every other portion of the network get reliable DNS lookups, the FreeBSD box does not.

Have a look at /etc/resolv.conf and see it the entries coincide with the actual dns server. If I understood you correctly in the first place, the FreeBSD box connects to the router and as such it will get it's dns IP's from it. See that the IP's in /etc/resolv.conf point to the router dns service.

Else, you could use your ISP's dns server IP's and bypass the router completely.
 
OP
dewarrn1

dewarrn1

New Member

Reaction score: 3
Messages: 19

Thanks for the reply, DD! It turns out that my problem was self-inflicted; my pf.conf file was blocking packets from all private networks on the outward-facing interface, resulting in no DNS service from the DSL modem's integrated router. Everything works after adjusting my pf configuration, so I'll try keeping it this way for a bit. I may try to restore something more like my old setup later on, though. Much appreciated!
 
Top