root mail

unicyclist

Member


Messages: 21

I am running FreeBSD mybox.my.domain 7.1-RC2 FreeBSD 7.1-RC2.
I don't get any local (system only) mail. It all stays in /var/spool/clientmqueue/
I can't "mail" myself or another user (or visa versa).

I've checked /etc/hosts with /etc/rc.conf and the name is the same.
I can ping localhost and mybox.my.domain. Sendmail is running, but /var/mail/root and /var/mail/mike remain empty.

What do I check next?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,291
Messages: 29,742

This may be a little counter intuitive but make sure sendmail_enable="NO" is in /etc/rc.conf. That will make sendmail run as a local submit only.

You can use the mailq command to see what's in the queue. Also make sure /etc/aliases is set up properly. Run newaliases if you make any changes in /etc/aliases.
 
OP
OP
U

unicyclist

Member


Messages: 21

mybox# mailq
/var/spool/mqueue is empty

/etc/aliases is setup correctly for user (mike) to receive roots email. Yes, I ran newaliases :)

Will try senmail_enable="NO". Hadn't thought of that. Thanks.
 
OP
OP
U

unicyclist

Member


Messages: 21

A bit more info:
$ sockstat -l4 -p 25
USER COMMAND PID FD PROTO LOCAL ADDRESS FOREIGN ADDRESS
root sendmail 734 4 tcp4 127.0.0.1:25 *:*

Also, I can't telnet localhost 25 either as root or normal user.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,780
Messages: 11,279

So none of these work?

Code:
telnet localhost 25
telnet 127.0.0.1 25
telnet 0 25
Tried [font="Fixedsys"]/etc/rc.d/sendmail restart[/font]? Something may be stuck. Any firewalling in place without a pass all or skip rule for lo0?
 
OP
OP
U

unicyclist

Member


Messages: 21

nope, telnet doesn't work to localhost.
I have stopped and started sendmail, and even rebooted. (I know, I know ;) )
Will check pf.conf. I am on another hd to run a bios upgrade for this old machine, so will get back with what I find in pf.conf.

Thanks for all the help/suggestions!
 
OP
OP
U

unicyclist

Member


Messages: 21

DutchDaemon, the problem was with pf.conf.
Don't know how the set skip lo0 got commented out but it was :(
Thanks for your help.
 
Top