Reboot wont automatically mount zpool

Hi I have zfs root and another zpool called snek
When I reboot I have to su to root and mount the zpool.
Why does it not automatically mount?
The pool is a 6T usb external drive.
11p2 amd64

loader.conf has zfs_load="YES"
rc.conf has ZFS enabled
Can you actually post rc.conf and output from zpool list, zfs list and mount after a reboot (before manually mounting anything).
It's very difficult to provide help if we can't see what your system is doing. You say you have zfs loaded and enabled but we have no way to confirm you haven't made a typo or mistake anywhere.

Regarding the second point, your drive is 6,000,000,000,000 bits. If you keep dividing this by 1024 to work out how many TB it is, you'll find it's approx 5.45TB. This is the same with pretty much all drives and always has been. You also lose a bit due to ZFS using/reserving some of the space.
I know it apparently got solved, but a common issue for this is not setting up /etc/rc.conf properly. In specific; make sure that you have added zfs_enable and set this to yes. This is a quote from my system:

## System services