Raspberry Pi 2 need to disable serial UART port on boot

ernie

Member


Messages: 32

I have a Raspberry Pi 2 running FreeBSD 11.0-RELEASE and I need to disable the serial port on boot up as it's interrupting the boot process. I have a GPS module attached to the UART port which spews out data to the Pi every second or so.

I tried disabling the port in /etc/ttys but that has no effect. I presume my problem has something to do with uboot setup.

Can someone point me in the right direction?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,771
Messages: 30,912

If you disable the UART you won't be able to access the GPS module at all. You probably just need to disable the serial console.
 

greatoak

New Member


Messages: 3

Hi!

Any solution for this?
I got the same problem: I can't get the u-boot to ignore input on serial.
 

greatoak

New Member


Messages: 3

I have created a file /boot/msdos/uEnv.txt with content:
Code:
bootdelay=0
stderr=lcd
stdout=lcd
At boot time with serial data coming in, the boot loader still stops displaying a continued line of "dots".

I didn't overlooked that part. This article explains how to recompile u-boot which is a NO-GO for me at the moment.


I have an urgent need to have this working so I am currently continuing deploying Raspbian at the moment... :(
 
Top