1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ralink rt2870 wifi support?

Discussion in 'Peripheral Hardware' started by tim-m89, Sep 14, 2009.

  1. greyulv

    greyulv New Member

    Messages:
    15
    Thanks Received:
    0
    No, must be when disabling the wired link and trying to bring up the wireless one. Only happens in Desktop. I have posted a link back to this thread from the PC-BSD forums.

    G
     
  2. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    And do not forget to send me bug reports, please. Thanks in advance.
    And i wanted to stop development and support of rt2860 for
    FreeBSD 7.2 :) It seems that it will not be the case now :e

    :e :e :e
     
  3. greyulv

    greyulv New Member

    Messages:
    15
    Thanks Received:
    0
    Will do. The newest release of PC-BSD was released yesterday 8 (Beta) and is based on FreeBSD 8.

    G
     
  4. tim-m89

    tim-m89 New Member

    Messages:
    123
    Thanks Received:
    0
    I tried "ifconfig rt28700 up" and that caused a kernel panick. Ifconfig shows the rt28700's status as "no carrier" and trying "ifconfig rt28700 192.168.2.102" says invalid argument.

    Edit Solved:

    The solution was to do "ifconfig wlan create wlandev rt28700" and then use the newly created wlan0 device instead.
     
  5. greyulv

    greyulv New Member

    Messages:
    15
    Thanks Received:
    0
    Egorenar, here is my dmesg output:

    Code:
    Copyright (c) 1992-2009 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.2-STABLE #11: Wed Jun 24 18:36:21 EDT 2009
        root@build7x32.pcbsd.org:/usr/obj/pcbsd-build72/cvs/7.2-src/sys/PCBSD
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Atom(TM) CPU N270   @ 1.60GHz (1596.02-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0x106c2  Stepping = 2
     Features=0xbfe9fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE> 
      Features2=0x40c39d<SSE3,DTES64,MON,DS_CPL,EST,TM2,SSSE3,xTPR,PDCM,<b22>>
      AMD Features=0x100000<NX> 
      AMD Features2=0x1<LAHF>
      Logical CPUs per core: 2
    [....]
    rt28600: <Ralink RT2790 PCIe> mem 0xfbef0000-0xfbefffff irq 19 at device 0.0 on pci1
    rt28600: attaching
    rt28600: EEPROM rev=0x0102
    rt28600: EEPROM mac address=00:22:43:5e:38:d8
    rt28600: EEPROM RF rev=0x0003, paths=1T2R
    rt28600: EEPROM NIC config: Tx AGC control=0, ext LNA gains=0/0
    rt28600: EEPROM country code=1/7
    rt28600: EEPROM freq offset=0x23
    rt28600: EEPROM led cntl=0x01, LEDs=0xffff/0x9ad9/0xc8cc
    rt28600: EEPROM LNA gains=0x00/0xff
    rt28600: invalid EEPROM LNA gain: 2
    rt28600: invalid EEPROM LNA gain: 3
    rt28600: EEPROM Tx power compensation deltas=0(2MHz), 0(5MHz)
    rt28600: EEPROM Tx power compensation #0=0x66663333(20MHz), 0x66663333(40MHz/2GHz), 0x66663333(40MHz/5GHz)
    rt28600: EEPROM Tx power compensation #1=0x66666666(20MHz), 0x66666666(40MHz/2GHz), 0x66666666(40MHz/5GHz)
    rt28600: EEPROM Tx power compensation #2=0x33333333(20MHz), 0x33333333(40MHz/2GHz), 0x33333333(40MHz/5GHz)
    rt28600: EEPROM Tx power compensation #3=0x66663333(20MHz), 0x66663333(40MHz/2GHz), 0x66663333(40MHz/5GHz)
    rt28600: EEPROM Tx power compensation #4=0xffff6666(20MHz), 0xffff6666(40MHz/2GHz), 0xffff6666(40MHz/5GHz)
    rt28600: EEPROM TSSI 2GHz: 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, step=255
    rt28600: EEPROM TSSI 5GHz: 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, step=255
    rt28600: invalid EEPROM powersave level
    rt28600: EEPROM powersave level=0x00ff
    rt28600: MAC/BBP RT2860 (rev 0x28720200), RF RT2720
    rt28600: Ethernet address: 00:22:43:5e:38:d8
    rt28600: [ITHREAD]
    [...]
    rt28600: initializing
    rt28600: loading 8051 microcode
    rt28600: 8051 microcode was successfully loaded
    rt28600: stopping
    rt28600: initializing
    rt28600: stopping
    rt28600: initializing
    rt28600: stopping
    [...]
    rt28600: initializing
    rt28600: link state changed to UP
    


    The card works but I am curious why it initializes multiple times?

    G
     
  6. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    Every time you or wpa_supplicant do "ifconfig up" or "ifconfig down" the NIC is initialized or stopped. It is OK.
     
  7. tim-m89

    tim-m89 New Member

    Messages:
    123
    Thanks Received:
    0
    My computer has been crashing at random times during the night. I have no idea what the cause is yet as I only installed freebsd on it because of this driver being available rather than crashing since I installed this driver. It could also be the latest nvidia driver (the first to support amd-64) or something completely different. Anyway here is a snippet of the dmesg on one of the crashes. The cipher error actually repeats a lot:

    Code:
    rt28700: rxinfo: cipher error=0x01
    rt28700: rxinfo: cipher error=0x01
    rt28700: rxinfo: cipher error=0x01
    rt28700: rxinfo: cipher error=0x01
    rt28700: rxinfo: cipher error=0x01
    rt28700: rxinfo: cipher error=0x01
    rt28700: rxinfo: cipher error=0x01
    rt28700: rxinfo: cipher error=0x01
    wlan0: link state changed to UP
    rt28700: rxinfo: cipher error=0x01
    wlan0: link state changed to DOWN
    Sleeping thread (tid 100104, pid 514) owns a non-sleepable lock
    panic: sleeping thread
    cpuid = 0
    Uptime: 12h22m55s
    Cannot dump. Device not defined or unavailable.
    Automatic reboot in 15 seconds - press a key on the console to abort
    Rebooting...
    cpu_reset: Stopping other CPUs
    


    How is this driver going for everybody else? I am trying to figure out if this was a coincidence.
     
  8. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    It is a rt28700 problem.
    Which mode do you use with rt2870 ?
    Crash dump would be very useful to help me fix this bug.

    "rt28700: rxinfo: cipher error=0x01" means that there were errors during frame decryption. Maybe wrong key.
     
  9. tim-m89

    tim-m89 New Member

    Messages:
    123
    Thanks Received:
    0
    I am not how you mean exactly but this is what I have in rc.conf:

    Code:
    wlans_rt28700="wlan0"
    ifconfig_wlan0="WPA inet 192.168.2.110 netmask 255.255.255.0 country NZ"
    defaultrouter="192.168.2.1"


    Read that It says "Cannot dump. Device not defined or unavailable"

    The key is correct and not changing and I am using the net a lot with it.

    Also this is not something that is easy to reproduce. I didn't think that the user app 'transmission' could cause this by itself but when it's going it is making hundreds of connections so I guess it could be stress testing the wifi driver?
     
  10. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    Thanks for feedback. I appreciate it.

    You are using STA mode.

    Do you have swap device, you could define it as crash dump device :)
     
  11. Halt

    Halt New Member

    Messages:
    3
    Thanks Received:
    0
    Rt2760

    Hi, I have wifi chipset RT2760, for this chipset uses ralink driver rt2860. But your driver does not find this chipset.

    Code:
    [gw] /home/wtf# kldstat
    Id Refs Address            Size     Name
     1   11 0xffffffff80100000 8f4ad8   kernel
     2    1 0xffffffff809f5000 1aa18    rt2860.ko
     3    1 0xffffffff80c22000 1c3a7    linux.ko
    [gw] /home/wtf# uname -a
    FreeBSD gw.loc 8.0-RELEASE-p1 FreeBSD 8.0-RELEASE-p1 #0: Wed Dec 30 21:49:11 MSK 2009     root@gw.loc:/usr/obj/usr/src/sys/ROUTER  amd64
    [gw] /home/wtf# pciconf -lvcb
    ...
    none2@pci0:4:0:0:       class=0x028000 card=0x27601814 chip=0x07011814 rev=0x00 hdr=0x00
        vendor     = 'Ralink Technology, Corp'
        class      = network
        bar   [10] = type Memory, range 32, base 0xd0400000, size 65536, enabled
        cap 01[40] = powerspec 3  supports D0 D3  current D0
    ...
    


    Thank you!
     
  12. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    Wait a minute, i will add your PCI IDs to my driver.
    I uploaded the new version of driver. Test it please.
     
  13. Halt

    Halt New Member

    Messages:
    3
    Thanks Received:
    0
    Hi, while I can not tested work in client mode, hostap mod does not work.

    Code:
    rt28600: <Ralink RT2760 PCI> mem 0xd0400000-0xd040ffff irq 17 at device 0.0 on pci4                                                             
    rt28600:attaching                                                
    rt28600: EEPROM rev=0x0102                                                       
    rt28600: EEPROM mac address=00:06:4f:76:3d:7b                                        
    rt28600: EEPROM RF rev=0x0003, paths=1T2R                                                       
    rt28600: EEPROM NIC config: HW radio cntl=0, Tx AGC cntl=0, ext LNA gains=0/0                                                        
    rt28600: EEPROM country code=255/255                                                     
    rt28600: EEPROM freq offset=0x28                                                      
    rt28600: EEPROM LED cntl=0x01, LEDs=0x5555/0x9e99/0x8d88                                                          
    rt28600: EEPROM LNA gains=0x00/0xff                                                  
    rt28600: invalid EEPROM LNA gain: 2                                                                
    rt28600: invalid EEPROM LNA gain: 3                                                                
    rt28600: EEPROM Tx power compensation deltas=0(2MHz), 0(5MHz)                                                          
    rt28600: EEPROM Tx power compensation #0=0xaacc6666(20MHz), 0xaacc6666(40MHz/2GHz), 0xaacc6666(40MHz/5GHz)                                           
    rt28600: EEPROM Tx power compensation #1=0xaacc6688(20MHz), 0xaacc6688(40MHz/2GHz), 0xaacc6688(40MHz/5GHz)                                           
    rt28600: EEPROM Tx power compensation #2=0xaacc6688(20MHz), 0xaacc6688(40MHz/2GHz), 0xaacc6688(40MHz/5GHz)                                           
    rt28600: EEPROM Tx power compensation #3=0xaacc6688(20MHz), 0xaacc6688(40MHz/2GHz), 0xaacc6688(40MHz/5GHz)                                           
    rt28600: EEPROM Tx power compensation #4=0xffff6688(20MHz), 0xffff6688(40MHz/2GHz), 0xffff6688(40MHz/5GHz)                                           
    rt28600: EEPROM TSSI 2GHz: 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, step=255                                                         
    rt28600: EEPROM TSSI 5GHz: 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, step=255                                                         
    rt28600: invalid EEPROM powersave level                                                            
    rt28600: EEPROM powersave level=0x00ff                                                     
    rt28600: MAC/BBP RT2860 (rev 0x28600102), RF RT2720                                                           
    rt28600: [ITHREAD] 
    


    Code:
    [gw] /home/wtf# cat /etc/rc.conf
    wlans_rt28600="wlan0"
    ifconfig_wlan0="inet 192.168.33.1 netmask 255.255.255.0 ssid FREE country RU"
    
    
    ifconfig
    ...
    rt28600: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
            ether 00:06:4f:76:3d:7b
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: associated
    wlan0: flags=8c43<UP,BROADCAST,RUNNING,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu 1500
            ether 00:06:4f:76:3d:7b
            inet 192.168.33.1 netmask 0xffffff00 broadcast 192.168.33.255
            media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
            status: no carrier
            ssid FREE channel 4 (2427 Mhz 11g)
            country US authmode OPEN privacy OFF txpower 0 bmiss 7 scanvalid 60
            protmode CTS wme burst bintval 0
    
    
    [gw] /home/wtf# ifconfig wlan0 inet 192.168.33.1 netmask 255.255.255.0 ssid FREE mode 11g mediaopt hostap
    ifconfig: SIOCSIFMEDIA (media): Device not configured
    [gw] /home/wtf# ifconfig wlan0 list caps
    drivercaps=4f85ed01<STA,IBSS,HOSTAP,AHDEMO,TXPMGT,SHSLOT,SHPREAMBLE,MONITOR,MBSS,WPA1,WPA2,BURST,WME,WDS,TXFRAG>
    cryptocaps=1b<WEP,TKIP,AES_CCM,TKIPMIC>
    [gw] /home/wtf# ifconfig -m wlan0
    wlan0: flags=8c43<UP,BROADCAST,RUNNING,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu 1500
            ether 00:06:4f:76:3d:7b
            inet 192.168.33.1 netmask 0xffffff00 broadcast 192.168.33.255
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: no carrier
            supported media:
                    <unknown subtype>
                    <unknown subtype>
                    media autoselect mode 11ng
                    media OFDM/54Mbps mode autoselect
                    media OFDM/48Mbps mode autoselect
                    media OFDM/36Mbps mode autoselect
                    media OFDM/24Mbps mode autoselect
                    media OFDM/18Mbps mode autoselect
                    media OFDM/12Mbps mode autoselect
                    media OFDM/9Mbps mode autoselect
                    media OFDM/6Mbps mode autoselect
                    media DS/11Mbps mode autoselect
                    media DS/5.5Mbps mode autoselect
                    media DS/2Mbps mode autoselect
                    media DS/1Mbps mode autoselect
                    media OFDM/54Mbps mode 11g
                    media OFDM/48Mbps mode 11g
                    media OFDM/36Mbps mode 11g
                    media OFDM/24Mbps mode 11g
                    media OFDM/18Mbps mode 11g
                    media OFDM/12Mbps mode 11g
                    media OFDM/9Mbps mode 11g
                    media OFDM/6Mbps mode 11g
                    media DS/11Mbps mode 11g
                    media DS/5.5Mbps mode 11g
                    media DS/2Mbps mode 11g
                    media DS/1Mbps mode 11g
                    media autoselect mode 11g
                    media DS/11Mbps mode 11b
                    media DS/5.5Mbps mode 11b
                    media DS/2Mbps mode 11b
                    media DS/1Mbps mode 11b
                    media autoselect mode 11b
                    media autoselect mode autoselect
            ssid FREE channel 11 (2462 Mhz 11g)
            country US authmode OPEN privacy OFF txpower 0 bmiss 7 scanvalid 60
            protmode CTS wme burst bintval 0
    
     
  14. Halt

    Halt New Member

    Messages:
    3
    Thanks Received:
    0
    These settings solved the problem with hostap.

    Code:
    create_args_wlan0="wlanmode hostap mode 11g"
    


    Works greate. But only mode 11g, not mode 11ng.

    Code:
    wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
            ether 00:06:4f:76:3d:7b
            inet 192.168.33.1 netmask 0xffffff00 broadcast 192.168.33.255
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap> (autoselect <hostap>)
            status: no carrier
            ssid "FREE " channel 1 (2412 Mhz 11b)
            country US authmode OPEN privacy OFF txpower 0 scanvalid 60 wme burst
            dtimperiod 1 -dfs
    
    ...
    
    wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500                          
            ether 00:06:4f:76:3d:7b                                                                      
            inet 192.168.33.1 netmask 0xffffff00 broadcast 192.168.33.255                                
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>                            
            status: running                                                                              
            ssid "FREE " channel 1 (2412 Mhz 11g) bssid 00:06:4f:76:3d:7b                                
            country US authmode OPEN privacy OFF txpower 0 scanvalid 60                                  
            protmode CTS wme burst dtimperiod 1 -dfs                                                     
    [gw] /home/wtf# ifconfig -m wlan0                                                                    
    wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500                          
            ether 00:06:4f:76:3d:7b                                                                      
            inet 192.168.33.1 netmask 0xffffff00 broadcast 192.168.33.255                                
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>                            
            status: running                                                                              
            supported media:                                                                             
                    <unknown subtype>                                                                    
                    <unknown subtype>                                                                    
                    media autoselect mode 11ng mediaopt hostap                                           
                    media OFDM/54Mbps mode autoselect mediaopt hostap                                    
                    media OFDM/48Mbps mode autoselect mediaopt hostap                                    
                    media OFDM/36Mbps mode autoselect mediaopt hostap                                    
                    media OFDM/24Mbps mode autoselect mediaopt hostap                                    
                    media OFDM/18Mbps mode autoselect mediaopt hostap                                    
                    media OFDM/12Mbps mode autoselect mediaopt hostap                                    
                    media OFDM/9Mbps mode autoselect mediaopt hostap                                     
                    media OFDM/6Mbps mode autoselect mediaopt hostap                                     
                    media DS/11Mbps mode autoselect mediaopt hostap                                      
                    media DS/5.5Mbps mode autoselect mediaopt hostap                                     
                    media DS/2Mbps mode autoselect mediaopt hostap                                       
                    media DS/1Mbps mode autoselect mediaopt hostap                                       
                    media OFDM/54Mbps mode 11g mediaopt hostap                                           
                    media OFDM/48Mbps mode 11g mediaopt hostap                                           
                    media OFDM/36Mbps mode 11g mediaopt hostap                                           
                    media OFDM/24Mbps mode 11g mediaopt hostap                                           
                    media OFDM/18Mbps mode 11g mediaopt hostap                                           
                    media OFDM/12Mbps mode 11g mediaopt hostap                                           
                    media OFDM/9Mbps mode 11g mediaopt hostap                                            
                    media OFDM/6Mbps mode 11g mediaopt hostap                                            
                    media DS/11Mbps mode 11g mediaopt hostap                                             
                    media DS/5.5Mbps mode 11g mediaopt hostap                                            
                    media DS/2Mbps mode 11g mediaopt hostap                                              
                    media DS/1Mbps mode 11g mediaopt hostap                                              
                    media autoselect mode 11g mediaopt hostap                                            
                    media DS/11Mbps mode 11b mediaopt hostap                                             
                    media DS/5.5Mbps mode 11b mediaopt hostap                                            
                    media DS/2Mbps mode 11b mediaopt hostap                                              
                    media DS/1Mbps mode 11b mediaopt hostap                                              
                    media autoselect mode 11b mediaopt hostap                                            
                    media autoselect mode autoselect mediaopt hostap                                     
            ssid "FREE " channel 1 (2412 Mhz 11g) bssid 00:06:4f:76:3d:7b                                
            country US authmode OPEN privacy OFF txpower 0 scanvalid 60                                  
            protmode CTS wme burst dtimperiod 1 -dfs                      
    
     
  15. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    HOSTAP configuration is a little different on FreeBSD 8.
    I had no opportunity to test my driver with rt2760 chip, so
    it is very good that you can test it now. Thanks for feedback.

    Yeah, i know, 802.11n is still work in progress :e

    Please send me any bug and problem reports.
    Thanks.

    :e :e :e
     
  16. gallon

    gallon New Member

    Messages:
    1
    Thanks Received:
    0
    Thank you Egorenar!

    Shame on me I wasted a day trying to get my rt2860 up directly :r

    Using config via wlan everything works okay (n.b. on 9.0-CURRENT@i386).

    Thx again. EEE is nothing without WiFi (or a gprs modem when in the country, hehe!)!
     
  17. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    I have finally added 802.11n support to rt2860 and rt2870 device drivers on FreeBSD 8 !!! :e
    It is working but still has some issues.
    HT 20MHz und 40MHz, A-MSDU, short GI are supported.
    A-MPDU and BlockAcks are still not supported.

    I'm actually surfing with HT40 mode but transfer rate is still not very good :-(

    The best transfer rate i got till now was 4.2 Mbyte /s :)

    I will test it a bit more and try to fix the problems.
    Then i will upload it here. But i need your feedback.
    Please send me bug and problem reports.
    Till now only 2-3 users sent me feedback regularly.

    :e :e :e
     
  18. code7395

    code7395 New Member

    Messages:
    24
    Thanks Received:
    0
  19. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    I need USB vendor and product ID of your NIC.
     
  20. code7395

    code7395 New Member

    Messages:
    24
    Thanks Received:
    0
    sorry,
    vid: 0x148f
    pid: 0x2770

    thanks
     
  21. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    You have Ralink RT2770 chip. The driver should support this chip.

    :e :e :e
     
  22. code7395

    code7395 New Member

    Messages:
    24
    Thanks Received:
    0
    fine,
    I compiled the two versions (fbsd8_amd64 + fbsd7.2_i386) over last days
    when trying to apply (rc.conf, ifconfig,netif restart..) suggestions on this topic my device remains recognized as ugen0 and never comes up.

    also, rt 28700 does not exist when i ifconfig-it, neitheir does wlan0, assigned by rc.conf
    can you think of a solution for my case.

    although i do the testings on both fbsd72i386 and pfsense 1.2.3, my need is to get it to work with pfsense.
    please help
    :\
     
  23. code7395

    code7395 New Member

    Messages:
    24
    Thanks Received:
    0
    if i just get it to work on freebsd the matter of pfsense is as easy as uploading the compiled module and kldloading it (that's not the problem)
     
  24. egorenar

    egorenar New Member

    Messages:
    199
    Thanks Received:
    20
    The driver should support it but i still need to add your device IDs or else it will not be detected.

    I uploaded the new driver version with 802.11n support and added your chip. Please test it and provide feedback. Thanks.

    Link: http://forums.freebsd.org/showpost.php?p=55365

    :e :e :e
     
  25. code7395

    code7395 New Member

    Messages:
    24
    Thanks Received:
    0
    thanks,
    i'll give feedback as soon as am finished with testing