Qugga OSPF and a remote vrrp address for a default route?

stubert

New Member


Messages: 2

I've searched around for an answer to what to do... Here is the problem I'm having:

Single FreeBSD system on a /24 network with six routers on it. Four of the 6 routers are internal gateways running OSPF and the other 2 are border routers running OSPF and BGP. The 2 border routers run VRRP to float the default route IP address from one to the other in the event of a problem. All servers on the /24 network are running Quagga OSPF. I am adding our first FreeBSD server to the network. When I brought up the OSPF daemon on the new FreeBSD server, the default route to the VRRP address became inactive. After some investigation, It appears that the kernel is tossing the route out because the OSPF daemon is receiving the a /32 address for the VRRP IP and calling it unreachable. I'm getting these errors in the log:
Code:
kernel: arplookup <router IP> failed: host is not on local network.
kernel: arpresolve: can't allocate route for <router IP>
I'm lost on this one... We have 60 or so Linux servers that are working perfectly in this same routing software settings. If I stop the OSPF daemon, everything routes fine to the VRRP address.

System is: 7.2-RELEASE FreeBSD 7.2-RELEASE #1
Quagga is quagga-0.99.12 from Ports

Any Help???

Stu
 
OP
OP
S

stubert

New Member


Messages: 2

Solved

Found a solution for this. Ended up creating a static route for the /32 address in Quagga. This route overrides the route advertisement received via OSPF.
 
Top