• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Xfce Problem with XDG dirs names.

Dendros

New Member


Messages: 9

#1
Hi, I'm new on this forum and I would like to ask about a problem I have with Xfce 4.12 on FreeBSD - it's the reason for I have registered here.
I have installed FreeBSD 11.1 on my machine, uname is:
Code:
FreeBSD system 11.1-RELEASE-p1 FreeBSD 11.1-RELEASE-p1 #0: Wed Aug  9 11:55:48 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
And then I installed Xfce on top of it and for some strange reason, the xdg-user-dirs-update command sets the folders' names to a different language than English. And yes, I have installed FreeBSD in English, I have modified the folders names in the user-dirs.dirs file to the English names and after I issue xdg-user-dirs-update, it reverts the names to the other language. Here is a screenshot of what my home looks like:

How can I solve this?
 

Attachments

lebarondemerde

Aspiring Daemon

Thanks: 362
Messages: 965

#2
Welcome!

I do not know what is going in there, but if it help it seems the system is somehow set to Afrikaans or Dutch.

O do not use XFCE but you could look in its config settings for something locale related. You could also run locale in terminal/console to see if there is something wrong in there.

EDIT: you can also take a look in HERE if you need to set anything locale related.
 

Dendros

New Member


Messages: 9

#3
Thanks. My locale is:

Code:
% locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_ALL=
My shell is tcsh and I have lightdm as login manager, if that matters. In fact I remember that in lightdm's login screen the locale on the top bar was set to a different language than English, initially I have not noticed this until the next login. Do you think it's related to my problem?
 

lebarondemerde

Aspiring Daemon

Thanks: 362
Messages: 965

#4
I never used x11/lightdm but the login manager often interfere/set the DE locale/language. Would be a good idea to change it to what you want and also look in the x11/lightdm config file if there is anything defaulting it to a language another than english.
 

Dendros

New Member


Messages: 9

#5
I think I have solved this by issuing the following command: xdg-user-dirs-update --force and the English names are now displayed.
 

Sensucht94

Active Member

Thanks: 138
Messages: 180

#6
I think I have solved this by issuing the following command: xdg-user-dirs-update --force and the English names are now displayed.
As far as it's only related to your folders' name, I guess it's an xdg issue, although I've never used /devel/xdg-user-dirs.

But if it's your XFCE evironment to have the language wrongly set, then it's probably related to lightdm.
I've used lightdm for quite some time in the past and noticed it tends to ignore /etc/login.conf and /etc/profile. Instead, in lack of a recognized configuration file, it sets the language according to keyboard layout, which is sometimes exactly what you want to avoid.

You can enable the language selector in the lightdm-gtk-greeter whether by adding
Code:
indicators=~language;
or
Code:
show-language-selector=true
to your /usr/local/etc/lightdm/lightdm-gtk-greeter.conf

If you look at this LightDM reference page, it clearly states LightDM seeks out /etc/environment for general env variables and ~/.dmrc for user's session options.
LightDM is really full of Linuxisms, some of them can be corrected editing /usr/local/etc/lightdm.conf.

So you might want to touch a ~/.dmrc file like this:
Code:
[Desktop]
Session=xfce4
Language=en_US.UTF-8
However I found LightDM correctly detects various shell configuration files like ~/.zshrc, ~/.profile and ~/.tcshrc.So if you're in Bourne shell you can set language in ~/.profile, like that:
Code:
LANG=en_US.UTF-8; export LANG
I haven't tried with LightDM, but usually the best way to set language in FreeBSD, the one I use now, is definitely editing ~/.login_conf, like that:
Code:
me:\
      :charset=UTF-8:\
      :lang=en_US.UTF-8:
And then run cap_mkdb ~/.login_conf

Give a look to login.conf(5), and to 22.2 Using Localization