Problem with installing vTiger


I tried to install a vTiger-CRM-System on my FreeBSD 10.2 FAMP.

Apache 2.4
PHP 5.6
MySQL 5.6

chown -R www:www vtiger
chmod -R 775 vtiger

When I install the System I navigate trough the web installer and put my information in the field. After that, I click on "Install" and then the installer script runs and create databases and other stuff. But every time after some seconds the page is just blank. When I refresh the site it shows me the login in the screen. When I check the Database, there are some missing tables. For me it looks like something with the execution time is wrong but I changed it to the recommend settings.

Does anyone have any idea?

Here is my php.ini
Last edited by a moderator:
Check your Apache error log. Most of the time this is because you're missing a needed PHP module.
Thanks for your Answer.
I checked the log and there are only some PHP Notice but no error or warning.

For example:

[Tue Apr 19 11:01:04.133558 2016] [:error] [pid 1556] [client] PHP Notice:  Undefined variable: mod_strings in /usr/local/www/apache24/data/vtigercrm/modules/CustomView/CustomVi
Thanks for your Help,

I checked the settings and added the following to my [FONT=Courier New]php.ini[/FONT]

register_globals = off
allow_call_time_pass_reference = On
safe_mode = off

This options was not my [FONT=Courier New]php.ini[/FONT] before.
[FONT=Arial]I tried to install the system again, but got the same problem.[/FONT]
Also note the settings for error_reporting. That might provide more info. I don't think it's anything FreeBSD specific, searching the error shows similar issues on Ubuntu and others.
Thanks for your answer!
My [FONT=Courier New]error_reporting[/FONT] looks like this actually
But still only get the notice. I will check if I find a thread or something with the same problem.

error_reporting = E_WARNING & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT