Problem starting freeradius

myha

Member


Messages: 35

Hello everyone,

I am trying to setup freeradius on FreeBSD and I have problems with starting the service. It compiled without problems, I am able to run it in the debug mode but not through rc script:

Code:
[root@polmer1 /]# /usr/local/etc/rc.d/radiusd start
[root@polmer1 /]#
Basically nothing really happens, I have checked the processes and it is not running, not error info or anything.

Any idea?

Thanks,
brm

EDIT: sorry, wrong forum. Please move.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,938
Messages: 11,346

Also, is there a radius_enable (or something) setting in rc.conf?
 
OP
myha

myha

Member


Messages: 35

Hi, radius log is empty, checked that already.

I can't find any setting for radius in rc.conf...
Code:
[root@polmer1 ~]# grep -i rad /etc/defaults/rc.conf
# values set in this file.  This eases the upgrade path when defaults
[root@polmer1 ~]#
 
OP
myha

myha

Member


Messages: 35

Ok, It looks like it exists:
Code:
radiusd_enable="YES"
:/ It works now.

so where can I find all the options for rc.conf?

Thanks for answers.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,938
Messages: 11,346

You will find the defaults in /etc/defaults/rc.conf (only use settings in /etc/rc.conf if you want to override those defaults). Port-specific settings are usually in the /usr/local/etc/rc.d/ start script.
 
OP
myha

myha

Member


Messages: 35

hi, as you can see above I tried to search for this setting but didnt find it.
 
Top