Problem shutting down

I just installed FreeBSD, and it doesn't shutdown properly. Whenever I enter "shutdown now", the system runs and "Enter full pathname of shell or RETURN for /bin/sh" appears. Is there a way to fix this? It doesn't appear when I enter "reboot" though.
I'm not sure, but maybe it helps to use the -h option (and possibly also -o)?

Oh, yes: and if your hardware supports it, do as DutchDaemon and SeanC propose:
"Shutdown now" actually switches the machine to single user mode. Hence the prompt for a shell.
Not really clearly ... tucked away in shutdown(8), and not really referring to command-line options

Corresponding signal is then sent to init(8) to respectively halt, reboot or bring the system down to single-user state (depending on the above options).

The absence of options (i.e. a single 'shutdown') is not discussed.
Actually did ;)

P.S.: update Dec 23: the requested explanation about omitting command-line switches has been added to man 8 shutdown.
bsddaemon said:
Im just wondering, if the console marked as insecure, in case I forgot root password, how can I recover then?

In /etc/ttys file:
console none                            unknown off insecure

Then you need to boot with a liveCD and set a new password.
Though not directly connected to the post...

If your are lazy add a nice alias for poweroff.

For csh/tcsh shell add this to your .cshrc file and source it:
alias poweroff  'shutdown -p now'

To source it:
source ~/.cshrc

To all users to shutdown add them to the operator group:
pw groupmod operator -m username