Problem installing amd64

I just got a AMD Sempron 3000+ computer and want to install FreeBSD 7.0 amd64 on it. But I got into trouble. Just before sysinstall starts I got lots of failures about the HDD. But sysinstall starts and I can go through all the options (although it changed the geometry of the hdd). But when installation will start formatting the harddrive it stops and says it can´t write to it. I tried another hdd and got the same problem. Both disks are IDE. The error message says something about DMA, i think there is some problem with the settings in bios. Or should i try disable DMA somehow through a safe mode setup and hope that it works better when it is installed.

Perhaps I should change it in BIOS from ultra DMA to PIO4 or something? But I guess it gets slower then when writing? I have seen on some forums that there is some bug in FreeBSD regarding DMA.

Got some more info that it could be some problem with to long cable or wo fast DMA setting.
this problem was solved by deisable DMA in boot load. I guess I have to get one of thos 80 pair cables.