powerd not working with fitlet-i (AMD A4-6400T)

I recently got a fitlet-i to try and use as a firewall. Unfortunately powerd doesn't seem to work with it. When I try to run powerd, I get a message like "cpufreq(4) not supported, file not found". I've tried to load a cpufreq kernel module but it said it's already loaded, I'm not really sure what file it's looking for.

From the stats link above, one can see that it has an AMD A4-6400T APU. I have another computer with an A6-3500 APU and that one does work. I'm not sure how to check if the CPU simply doesn't support the functionality required by cpufreq and powerd, and can't find a list of supported stuff by powerd or cpufreq...

I read online that enabling sleep states in the BIOS might help, so I'll try that later today (I have to dismantle this setup first, move the monitor, etc.), in case those are disabled, assuming they are in the BIOS somewhere. I did notice when I was in the BIOS initially that it lets me set a TDP value. Unfortunately that isn't really very useful since it's a static setting, where powerd would be dynamic, going up and down as needed...

Does anyone have insight into why this might not work or things I could try to get it working?


Edit: After more searching I found this link, that suggests disabling ACPI throttling (or something), which I will also try when I get back from work...
Well, those tips didn't work. I read elsewhere that for some people 10.3 didn't work but 10.1 did, so I guess I'll try using earlier versions and see if this is a regression...
powerd(8) does not work with either 10.3 or 10.2. Both versions produce the same error regardless of having hint.acpi_throttle.0.disabled="1" in /boot/loader.conf:

powerd: no cpufreq(4) support -- aborting: No such file or directory
However 10.1 seems to work, even without adding the hint to loader.conf. powerd(8) starts up as normal and reports that it is lowering the CPU frequency and sysctl(8) reports the frequency as if powerd(8) was working:

root@goly:/ # powerd -v -a adaptive -b adaptive -n adaptive -p 1000
powerd: unable to determine AC line status
load   0%, current freq  623 MHz ( 3), wanted freq  545 MHz
changing clock speed from 249 MHz to 124 MHz
load   3%, current freq  124 MHz ( 7), wanted freq  124 MHz
load   4%, current freq  124 MHz ( 7), wanted freq  124 MHz
I say "seems to work" because I'm not sure if this is just a false positive for these reasons:
  • I have not found anywhere a mention of this CPU supporting PowerNow! or Cool'n'Quiet, which from what I can tell are the technologies that powerd(8) and/or cpufreq use to change the CPU frequency, so I am not sure if the CPU hardware even supports changing the frequency.
  • The temperature of the heat sink doesn't seem to change at all. I don't have a infrared thermometer to verify but just touching it, it's just as hot as before, but this is very subjective.
  • The power draw of the device has not changed at all, and I would have expected a noticeable drop. The CPU dropped from ~600MHz to ~100MHz, allegedly, but maybe this is not a large enough change to warrant a watt drop in power draw.
Interestingly, with hint.acpi_throttle.0.disabled="1" in /boot/loader.conf, powerd(8) stops working. Maybe 10.2 and 10.3 disable it by default?

I also noticed a couple reboots while powerd(8) was running, so maybe it isn't stable with that anyway...the one time I was watching when this happened, powerd(8) changed the frequency from 124 MHz to 724MHz (or thereabouts), the system froze immediately for a second and rebooted. The BIOS lists the speed as minimum 600 MHz, maximum 1000 MHz or so, and a boot speed... I'm beginning to think this CPU just doesn't do it.