I have a faulty disk in raidz1 pool, it keeps disappearing from time to time. So, I removed it and replaced. The funny situation that the new disk was faulty as well.
Resilvering started, but emitted checksum errors. So, I shutdowned the system and returned faulty drive. I've planned to online it and resilver.
The problem:
1. data0 is faulty resilvering target, removed.
2. gptid/5416f821-9314-11ef-b60b-a8b8e000d71b is the disk that likes to disappear. It represents pool state in the past (say, 1 day ago, because it wasn't resilvered after disappearing to the present state).
Other disks are OK.
The pool shows problem with 1 disk, from my point of view it has enough replicas to function.
I've emitted -FX, it didn't returned, but the disks show activity. Probably, I shouldn't use -X before asking for help and definitely should try to import without both data0 and gptid/5416f821-9314-11ef-b60b-a8b8e000d71b , but still - why failure in one device brought entire pool down?
Resilvering started, but emitted checksum errors. So, I shutdowned the system and returned faulty drive. I've planned to online it and resilver.
The problem:
Code:
abishai@beta:~ % doas zpool import
pool: zdata
id: 6286655327721895903
state: FAULTED
status: The pool metadata is corrupted.
action: The pool cannot be imported due to damaged devices or data.
The pool may be active on another system, but can be imported using
the '-f' flag.
see: https://openzfs.github.io/openzfs-docs/msg/ZFS-8000-72
config:
zdata FAULTED corrupted data
raidz1-0 DEGRADED
replacing-0 DEGRADED
gptid/5416f821-9314-11ef-b60b-a8b8e000d71b ONLINE
gpt/data0 FAULTED corrupted data
gpt/data1 ONLINE
gpt/data2 ONLINE
gpt/data3 ONLINE
logs
mirror-1 ONLINE
gpt/zil0 ONLINE
gpt/zil1 ONLINE
1. data0 is faulty resilvering target, removed.
2. gptid/5416f821-9314-11ef-b60b-a8b8e000d71b is the disk that likes to disappear. It represents pool state in the past (say, 1 day ago, because it wasn't resilvered after disappearing to the present state).
Other disks are OK.
Code:
abishai@beta:~ % doas zpool import -F zdata
cannot import 'zdata': I/O error
Destroy and re-create the pool from
a backup source.
The pool shows problem with 1 disk, from my point of view it has enough replicas to function.
I've emitted -FX, it didn't returned, but the disks show activity. Probably, I shouldn't use -X before asking for help and definitely should try to import without both data0 and gptid/5416f821-9314-11ef-b60b-a8b8e000d71b , but still - why failure in one device brought entire pool down?