• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Pkg broken after upgrade to 10.0.4 on aarch64 (RPI)

Spartrekus

Well-Known Member

Thanks: 45
Messages: 288

#1
Hello,

I bring with xzcat the FreeBSD Version 12 on an SD. I start.

pkg install and after upgrade, (since yesterday) the PKG package does not want to do anything.

Pkg broken after upgrade to 10.0.4 on aarch64 (RPI)

Any help would be greatly welcome.

I need Subversion, gcc and vim (ideally tcc too !! )
 

Phishfry

Son of Beastie

Thanks: 875
Messages: 2,661

#4
Maybe the FreeBSD 11, for RPI2, would be more stable?
Much more stable. Plus 11.1 is faster due to witness and debug options used on -CURRENT which slows it down.
Just make sure it is RPi2B v1.1 and not RPi2B v1.2
There are two distinct different CPU's on v1.1 and v1.2. The board is marked 1.1 or 1.2. They look nearly identical.
You need version 1.1 RPI2B
 

Spartrekus

Well-Known Member

Thanks: 45
Messages: 288

#5
Much more stable. Plus 11.1 is faster due to witness and debug options used on -CURRENT which slows it down.
Just make sure it is RPi2B v1.1 and not RPi2B v1.2
There are two distinct different CPU's on v1.1 and v1.2. The board is marked 1.1 or 1.2. They look nearly identical.
You need version 1.1 RPI2B
With RPI2 FreeBSD 11 image, the raspberry RPI 3 model B does not boots / starts. It stays red/blue/... colors and hangs.

FreeBSD 12 RPI3 could at least start, but allas / so much pitty that PKG is broken.
there is too issue with libdl.so.1 missing, subversion package is gone :(
too bad :( :( sadness#

big sadness # of not having FreeBSD on my RPI machines any longer due to this bug/issue or whatever one may call it.

which image for RPI3B or (version 1.1 RPI2B) would you recommend to give a try ?

Will FreeBSD 12.x support RPI3B at some point?

Any chances to run a RPI3B powered by FreeBSD ?
 

Spartrekus

Well-Known Member

Thanks: 45
Messages: 288

#9
there is no single chance to do anything since pkg will ask to upgrade at first: pkg install

FreeBSD is completely broken for RPI . same story here http://www.raspbsd.org/


no one can use freebsd on arm :(

It happened yesterday ! the change to 10.0.4 pkg version broken, means, any freebsd using rpi.

everyone is concerned.
 

Spartrekus

Well-Known Member

Thanks: 45
Messages: 288

#13
The method below does not work.

pkg install after the env ABI stuffs, gives then installing pkg-1.10.4 , ok, 100pct , but then FreeBSD is dead.
completely since pkg went inside, shared object "libarchive.so.6 not found, required by "PKG"



not working:

Code:
To bootstrap pkg, run:
env ABI=FreeBSD:11:aarch64 pkg bootstrap


To set up pkg to use the 11 repo, add the following to your /usr/local/etc/pkg.conf:
ABI = "FreeBSD:11:aarch64";

PLEASE H E L P | H E L P
 

acheron

Well-Known Member

Thanks: 173
Messages: 440

#14
Your image is 7 months old (svn r320146 Tue Jun 20 14:35:19 2017), and you're trying to install packages for the wrong version, what can go wrong?
 

Spartrekus

Well-Known Member

Thanks: 45
Messages: 288

#15
Your image is 7 months old (svn r320146 Tue Jun 20 14:35:19 2017), and you're trying to install packages for the wrong version, what can go wrong?
Same results using all images.

In my opinion 2018-01-10 is not old at all, but simply very recent.
ftp://ftp.freebsd.org/pub/FreeBSD/s...NT-arm64-aarch64-RPI3-20180110-r327788.img.xz


Maybe some one would like to make a clear help or solution ?

Hopefully FreeBSD, one day, will run on RPI 3 model b (with pkg working)??
 

Spartrekus

Well-Known Member

Thanks: 45
Messages: 288

#17
thank you about Subversion.

I can live without it until I get GCC. If GCC, I can compile anything from source.


Ok, anyhow, Would someone tell me how to get PKG working on FreeBSD to live with Freebsd on RPI3b?
 

Spartrekus

Well-Known Member

Thanks: 45
Messages: 288

#22
Just use pkg install pkg, pkg-static is usefull when pkg is borked
the problem is that it misses after the libarchive.so.6.

root
root

then I believe that 12 current may work, no? (packages)

With 12, it outputs after the usual : pkg install pkg:
Code:
pkg install
Shared object "libarchive.so.6" not found, required by "pkg"
 

Spartrekus

Well-Known Member

Thanks: 45
Messages: 288

#24
Paste /etc/pkg/*.conf, and paste the command you are using.
Code:
$ 
$ 
$ cat /etc/pkg/*.conf
# $FreeBSD: head/etc/pkg/FreeBSD.conf 263937 2014-03-30 15:24:17Z bdrewery $
#
# To disable this repository, instead of modifying or removing this file,
# create a /usr/local/etc/pkg/repos/FreeBSD.conf file:
#
#   mkdir -p /usr/local/etc/pkg/repos
#   echo "FreeBSD: { enabled: no }" > /usr/local/etc/pkg/repos/FreeBSD.conf
#

FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/share/keys/pkg",
  enabled: yes
}
$

Code:
pkg install pkg 
pkg install gcc svnlite ncurses nano



would be greatly useful.
 

acheron

Well-Known Member

Thanks: 173
Messages: 440

#25
I don't know what mistake you're doing but upstream pkg doesn't have the libarchive.so.6 dependency (it's libarchive.so.7)
Are you still setting the ABI to FreeBSD:11:aarch64?

To fix your problem, execute the following:

fetch http://pkg.freebsd.org/FreeBSD:12:aarch64/latest/Latest/pkg.txz
pkg-static add -f pkg.txz
 
Top