Solved Perplexities about the sound system

Nicola Mingotti

Well-Known Member

Reaction score: 198
Messages: 494

Hi guys,

I don't understand well what is happening in the sound system,
I hope some of you can give me some directions because I have
very scarce knowledge in this field.

I am running my FreeBSD-11.1 in a VMWare virtual machine into
a MacbookPro 2009.

This is my configuration related to suound
---- /boot/loader.conf
sound_load="YES"
snd_hda_load="YES"
speaker_load="YES"
----

The cat /dev/sndstat says:
Code:
FreeBSD Audio Driver (64bit 2009061500/amd64)
Installed devices:
pcm0: <AudioPCI ES1371-A> at io 0x2040 irq 16  (2p:1v/1r:1v) default
No devices installed from userspace.
-] Question [1]. Why does it say No devices installed from userspace, what does it mean?

[*] Fact, my sound system works, if I run mplayer its works and if I run
Youtube from chrome I hear the music, so ok, from this point of view.

-] I don't have any /dev/pcm devices, I see in the Handbook i should see them.
Why is it so ? (Question [2])

Question [3]. If I don't have sound devices listed in /dev/ how can my system play
music ?

I tried to run truss on mplayer but here things become
still more confusing, I see this line
Code:
openat(AT_FDCWD,"/dev/dsp",O_WRONLY,00)
So, mplayer is opening "/dev/dsp" but I don't see that file in /dev !
Or at least, /dev/dsp does not appear untill i run mplayer !
 
OP
Nicola Mingotti

Nicola Mingotti

Well-Known Member

Reaction score: 198
Messages: 494

I fund this in man pcm
Code:
The above device nodes are only created on demand through the dynamic
devfs(5) clone handler.  Users are strongly discouraged to access them
directly.  For specific sound card access, please instead use /dev/dsp or
/dev/dsp%d.
This partially explains my doubts.
 
Top