Patching file failed


I have a fresh FreeBSD 7.1 installation for testing and learning purposes. Today I updated my ports tree and noticed that there was an update to glib and irssi was compiled using the old version of glib. I tried to update them with portmanager -u but I got following error at the end of update:

reverting patch -=>cd /usr/ports/Mk; patch -R < /usr/local/share/portmanager/;
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
|--- /usr/ports/Mk/	Tue Nov  8 01:02:51 2005
|+++	Wed Nov 16 02:16:57 2005
Patching file using Plan A...
Hunk #1 failed at 2049.
1 out of 1 hunks failed--saving rejects to

portmanager -s shows that glib got updated but being new to FreeBSD the error bothers me and I'd like to know how to fix it.

I tried to google some help and I found a few posts with similar errors but all I got from them was that it's related to portmanager and that I could avoid errors by using portupgrade instead.
Thanks ale, I'll check that file if I can make something out of it.

Same thing happened when I upgraded Perl. Maybe I'll change to portupgrade.
The patch to is harmless. It can safely be ignored. I asked rnoland@ via IRC directly a few weeks back.