• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

opensmtp refuses to start after update

k-nike

Member

Thanks: 2
Messages: 24

#27
herot said:
Knight didn't work.
Code:
Feb  7 07:58:05 hoth smtpd[26546]: fatal: msgbuf_write: Socket is not connected
k-nike! Not Knigth! :)

I think you are running other e-mail program that listens to port 25. Likely sendmail. Do you disable it?

Need result:
Code:
sockstat -4 | grep :25
If you saw something (for example sendmail), you need disable it:
Code:
/etc/rc.d/sendmail stop
next
Code:
/usr/local/etc/rc.d/smtpd start
Next disable sendmail in /etc/rc.conf:
Code:
...
smtpd_enable="YES"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
 

herot

New Member


Messages: 11

#28
sendmail was already disabled. sockstat revealed no sendmail.

/etc/rc.conf
Code:
# Disable Sendmail
sendmail_enable="NO"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"

# start smtpd instead of sendmail
smtpd_enable="YES"
 

k-nike

Member

Thanks: 2
Messages: 24

#29
1. Do you have root access?
2. Which version opensmtpd is used?
3. Try to install the last version opensmtpd-201302051638 from ports.
 

k-nike

Member

Thanks: 2
Messages: 24

#33
i have:
Code:
/usr/local/etc/mail             root:wheel  755
/usr/local/etc/mail/smtpd.conf  root:wheel  644
/usr/local/etc/mail/secrets     root:_smtpd 640
/usr/local/etc/mail/secrets.db  root:_smtpd 640
/usr/local/etc/mail/aliases     root:wheel  640
/usr/local/etc/mail/aliases.db  root:wheel  640
 
Top