Solved OpenGL failed to load

After upgrading to FreeBSD 11.0 I notice that all my KDE desktop eye candy disappeared. A quick glxinfo revealed a permission problem with LibGL. A quick search here found a 2 year old post by Coldfire MC @ Thread 48345. Same fix i.e. #chmod 777 /dev/dri/card0 + a logout/login and re-enable desktop effects under advanced tab in system settings solved it all. That's it except for; why?
I do believe that it is also a good idea to portsnap fetch update before committing to a major version bump. It just cost me some extra time while upgrading that's all.
That's it except for; why?

Most likely:

From Handbook: 5.4.2. User Group for Accelerated Video
Access to /dev/dri is needed to allow 3D acceleration on video cards. It is usually simplest to add the user who will be running X to either the video or wheel group.
Adding 'user' to video group made it permanent. Thanks. Previously had been using fully patched FreeBSD 10.3 and this had never come up. In fact ever since acceleration was fixed for intel GPU's (I think it was FreeBSD 10) I have not had a single issue. In any case FreeBSD 11.0 upgrade was a breeze save for a few ABI issues that were easy to fix. Great job.