Nvidia - Laptop On-board Display Problem

Greetings,

I've run into a little trouble with my laptop. It seems x11/nvidia-driver will work via my external display (HDMI), but not via the on-board display. I've been at this for a while and just can't wrap my head around it. Any advice/info would be great! Xorg logs and dmesg are attached. Thank you in advanced! :)

~Alex

Code:
[ 22.172] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 1070 (GP104-A) at PCI:1:0:0 (GPU-0)
[ 22.172] (--) NVIDIA(0): Memory: 8388608 kBytes
[ 22.172] (--) NVIDIA(0): VideoBIOS: 86.04.33.00.04
[ 22.172] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 22.203] (--) NVIDIA(GPU-0): SAMSUNG (DFP-0): connected
[ 22.203] (--) NVIDIA(GPU-0): SAMSUNG (DFP-0): Internal TMDS
[ 22.203] (--) NVIDIA(GPU-0): SAMSUNG (DFP-0): 600.0 MHz maximum pixel clock
[ 22.203] (--) NVIDIA(GPU-0):
[ 22.203] (--) NVIDIA(GPU-0): DFP-1: disconnected
[ 22.204] (--) NVIDIA(GPU-0): DFP-1: Internal DisplayPort
[ 22.204] (--) NVIDIA(GPU-0): DFP-1: 960.0 MHz maximum pixel clock
[ 22.204] (--) NVIDIA(GPU-0):
[ 22.204] (--) NVIDIA(GPU-0): DFP-2: disconnected
[ 22.204] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[ 22.204] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[ 22.204] (--) NVIDIA(GPU-0):


/boot/loader.conf
Code:
zfs_load="YES"
#hw.vga.textmode=1
kern.vty=vt
kern.vt.fb.default_mode="1920x1080"
linux_enable="YES"
nvidia-modeset_load="YES"


pciconf -lv
Code:
hostb0@pci0:0:0:0:   class=0x060000 card=0x11de1462 chip=0x59108086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers'
    class      = bridge
    subclass   = HOST-PCI
pcib1@pci0:0:1:0:   class=0x060400 card=0x11de1462 chip=0x19018086 rev=0x05 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Skylake PCIe Controller (x16)'
    class      = bridge
    subclass   = PCI-PCI
vgapci1@pci0:0:2:0:   class=0x030000 card=0x11de1462 chip=0x591b8086 rev=0x04 hdr=0x00
    vendor     = 'Intel Corporation'
    class      = display
    subclass   = VGA
xhci0@pci0:0:20:0:   class=0x0c0330 card=0x11de1462 chip=0xa12f8086 rev=0x31 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H USB 3.0 xHCI Controller'
    class      = serial bus
    subclass   = USB
none0@pci0:0:20:2:   class=0x118000 card=0x11de1462 chip=0xa1318086 rev=0x31 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H Thermal subsystem'
    class      = dasp
none1@pci0:0:22:0:   class=0x078000 card=0x11de1462 chip=0xa13a8086 rev=0x31 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H CSME HECI'
    class      = simple comms
ahci0@pci0:0:23:0:   class=0x010400 card=0x11de1462 chip=0x282a8086 rev=0x31 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801 Mobile SATA Controller [RAID mode]'
    class      = mass storage
    subclass   = RAID
pcib2@pci0:0:28:0:   class=0x060400 card=0x11de1462 chip=0xa1108086 rev=0xf1 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib3@pci0:0:28:3:   class=0x060400 card=0x11de1462 chip=0xa1138086 rev=0xf1 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib4@pci0:0:28:4:   class=0x060400 card=0x11de1462 chip=0xa1148086 rev=0xf1 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
isab0@pci0:0:31:0:   class=0x060100 card=0x11de1462 chip=0xa1528086 rev=0x31 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H LPC Controller'
    class      = bridge
    subclass   = PCI-ISA
none2@pci0:0:31:2:   class=0x058000 card=0x11de1462 chip=0xa1218086 rev=0x31 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H PMC'
    class      = memory
hdac1@pci0:0:31:3:   class=0x040300 card=0x11de1462 chip=0xa1718086 rev=0x31 hdr=0x00
    vendor     = 'Intel Corporation'
    class      = multimedia
    subclass   = HDA
none3@pci0:0:31:4:   class=0x0c0500 card=0x11de1462 chip=0xa1238086 rev=0x31 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Sunrise Point-H SMBus'
    class      = serial bus
    subclass   = SMBus
vgapci0@pci0:1:0:0:   class=0x030000 card=0x11de1462 chip=0x1ba110de rev=0xa1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'GP104M [GeForce GTX 1070 Mobile]'
    class      = display
    subclass   = VGA
hdac0@pci0:1:0:1:   class=0x040300 card=0x00000000 chip=0x10f010de rev=0xa1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'GP104 High Definition Audio Controller'
    class      = multimedia
    subclass   = HDA
none4@pci0:2:0:0:   class=0x028000 card=0x21108086 chip=0x24fb8086 rev=0x10 hdr=0x00
    vendor     = 'Intel Corporation'
    class      = network
alc0@pci0:3:0:0:   class=0x020000 card=0x11de1462 chip=0xe0b11969 rev=0x10 hdr=0x00
    vendor     = 'Qualcomm Atheros'
    class      = network
    subclass   = ethernet
xhci1@pci0:4:0:0:   class=0x0c0330 card=0x11de1462 chip=0x12421b21 rev=0x00 hdr=0x00
    vendor     = 'ASMedia Technology Inc.'
    device     = 'ASM1142 USB 3.1 Host Controller'
    class      = serial bus
    subclass   = USB


../X11/xorg.conf.d/driver-nvidia.conf
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
EndSection


dmesg
Code:
With External HDMI
==================
nvidia0: <GeForce GTX 1070> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io
hdac0: <NVIDIA (0x10f0) HDA Controller> mem 0xdf080000-0xdf083fff irq 17 at device 0.1 on pci1
vgapci1: <VGA-compatible display> port 0xf000-0xf03f mem 0xdd000000-0xddffffff,0xb0000000-0xbfffffff irq 16 at device 2.0 on pci0
vgapci1: Boot video device

Without External HDMI
=====================
nvidia0: <GeForce GTX 1070> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io
vgapci1: <VGA-compatible display> port 0xf000-0xf03f mem 0xdd000000-0xddffffff,0xb0000000-0xbfffffff irq 16 at device 2.0 on pci0
vgapci1: Boot video device
 

Attachments

  • dmesg.txt
    11.6 KB · Views: 414
  • Xorg.0.log.with.hdmi.txt
    9.6 KB · Views: 336
  • Xorg.0.log.without.hdmi.txt
    6.7 KB · Views: 358
Assuming it's a Samsung Odyssey model (that was the only Samsung laptop with a GTX1070 I could find), it looks like this laptop uses Optimus and it's using the Intel GPU to drive the internal display. According to your Xorg.0.log there's nothing attached to the NVidia card when you're using the internal display. Is there a BIOS/UEFI setting that allows you to switch off the Intel GPU completely?

Optimus has been problematic in the past and I'm not sure what the current status is.
 
Assuming it's a Samsung Odyssey model (that was the only Samsung laptop with a GTX1070 I could find), it looks like this laptop uses Optimus and it's using the Intel GPU to drive the internal display. According to your Xorg.0.log there's nothing attached to the NVidia card when you're using the internal display. Is there a BIOS/UEFI setting that allows you to switch off the Intel GPU completely?

Optimus has been problematic in the past and I'm not sure what the current status is.

Thank you for your input! The laptop is a MSI GP72MVR-7RGX. I checked the BIOS, with no success. Can not disable the Intel GPU.
 
Notes:

Xorg -configure =
../xorg.conf.new

Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/local/lib/xorg/modules"
   FontPath     "/usr/local/share/fonts/misc/"
   FontPath     "/usr/local/share/fonts/TTF/"
   FontPath     "/usr/local/share/fonts/OTF/"
   FontPath     "/usr/local/share/fonts/Type1/"
   FontPath     "/usr/local/share/fonts/100dpi/"
   FontPath     "/usr/local/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/sysmouse"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "Monitor1"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                 # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "CustomEDID"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "Present"               # [<bool>]
        #Option     "ColorKey"               # <i>
        #Option     "VideoKey"               # <i>
        #Option     "Tiling"                 # [<bool>]
        #Option     "LinearFramebuffer"      # [<bool>]
        #Option     "HWRotation"             # [<bool>]
        #Option     "VSync"                 # [<bool>]
        #Option     "PageFlip"               # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"           # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"         # [<bool>]
        #Option     "XvMC"                   # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "VirtualHeads"           # <i>
        #Option     "TearFree"               # [<bool>]
        #Option     "PerCrtcPixmaps"         # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"      # [<bool>]
        #Option     "DebugFlushCaches"       # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Device"
   Identifier  "Card1"
   Driver      "nvidia"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
       Viewport   0 0
       Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "Card1"
   Monitor    "Monitor1"
   SubSection "Display"
       Viewport   0 0
       Depth     24
   EndSubSection
EndSection

../Xorg.0.log
Code:
[   641.486]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[   641.486] X Protocol Version 11, Revision 0
[   641.486] Build Operating System: FreeBSD 12.0-CURRENT amd64
[   641.486] Current Operating System: FreeBSD leo 12.0-CURRENT FreeBSD 12.0-CURRENT #0 r320095: Mon Jun 19 14:29:51 UTC 2017     root@releng3.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
[   641.487] Build Date: 18 June 2017  01:25:19PM
[   641.487]
[   641.487] Current version of pixman: 0.34.0
[   641.487]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   641.487] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   641.488] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 21 17:13:19 2017
[   641.488] (++) Using config file: "/root/xorg.conf.new"
[   641.488] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[   641.489] (==) ServerLayout "X.org Configured"
[   641.489] (**) |-->Screen "Screen0" (0)
[   641.489] (**) |   |-->Monitor "Monitor0"
[   641.489] (**) |   |-->Device "Card0"
[   641.490] (**) |-->Screen "Screen1" (1)
[   641.490] (**) |   |-->Monitor "Monitor1"
[   641.490] (**) |   |-->Device "Card1"
[   641.490] (**) |-->Input Device "Mouse0"
[   641.490] (**) |-->Input Device "Keyboard0"
[   641.490] (==) Automatically adding devices
[   641.490] (==) Automatically enabling devices
[   641.490] (==) Not automatically adding GPU devices
[   641.491] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   641.491] (**) FontPath set to:
   /usr/local/share/fonts/misc/,
   /usr/local/share/fonts/TTF/,
   /usr/local/share/fonts/OTF/,
   /usr/local/share/fonts/Type1/,
   /usr/local/share/fonts/100dpi/,
   /usr/local/share/fonts/75dpi/,
   /usr/local/share/fonts/misc/,
   /usr/local/share/fonts/TTF/,
   /usr/local/share/fonts/OTF/,
   /usr/local/share/fonts/Type1/,
   /usr/local/share/fonts/100dpi/,
   /usr/local/share/fonts/75dpi/
[   641.491] (**) ModulePath set to "/usr/local/lib/xorg/modules"
[   641.491] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   641.491] (WW) Disabling Mouse0
[   641.492] (WW) Disabling Keyboard0
[   641.492] (II) Loader magic: 0x80cc10
[   641.492] (II) Module ABI versions:
[   641.492]    X.Org ANSI C Emulation: 0.4
[   641.492]    X.Org Video Driver: 20.0
[   641.492]    X.Org XInput driver : 22.1
[   641.492]    X.Org Server Extension : 9.0
[   641.492] (!!) More than one possible primary device found
[   641.492] (--) PCI: (0:0:2:0) 8086:591b:1462:11de rev 4, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/65536
[   641.493] (--) PCI: (0:1:0:0) 10de:1ba1:1462:11de rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/65536
[   641.493] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   641.493] (II) LoadModule: "glx"
[   641.494] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[   641.581] (II) Module glx: vendor="NVIDIA Corporation"
[   641.581]    compiled for 4.0.2, module version = 1.0.0
[   641.581]    Module class: X.Org Server Extension
[   641.581] (II) NVIDIA GLX Module  375.66  Mon May  1 14:55:58 PDT 2017
[   641.582] (II) LoadModule: "intel"
[   641.582] (II) Loading /usr/local/lib/xorg/modules/drivers/intel_drv.so
[   641.583] (II) Module intel: vendor="X.Org Foundation"
[   641.583]    compiled for 1.18.4, module version = 2.99.917
[   641.583]    Module class: X.Org Video Driver
[   641.584]    ABI class: X.Org Video Driver, version 20.0
[   641.584] (II) LoadModule: "nvidia"
[   641.584] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[   641.589] (II) Module nvidia: vendor="NVIDIA Corporation"
[   641.589]    compiled for 4.0.2, module version = 1.0.0
[   641.590]    Module class: X.Org Video Driver
[   641.590] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   641.593] (II) intel: Driver for Intel(R) HD Graphics
[   641.593] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[   641.593] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[   641.593] (II) NVIDIA dlloader X Driver  375.66  Mon May  1 14:35:35 PDT 2017
[   641.593] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   641.594] (--) Using syscons driver with X support (version 2.0)
[   641.594] (--) using VT number 9

[   641.618] (II) Loading sub module "fb"
[   641.618] (II) LoadModule: "fb"
[   641.618] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[   641.902] (II) Module fb: vendor="X.Org Foundation"
[   641.902]    compiled for 1.18.4, module version = 1.0.0
[   641.902]    ABI class: X.Org ANSI C Emulation, version 0.4
[   641.902] (II) Loading sub module "wfb"
[   641.902] (II) LoadModule: "wfb"
[   641.903] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[   641.969] (II) Module wfb: vendor="X.Org Foundation"
[   641.969]    compiled for 1.18.4, module version = 1.0.0
[   641.969]    ABI class: X.Org ANSI C Emulation, version 0.4
[   641.969] (II) Loading sub module "ramdac"
[   641.969] (II) LoadModule: "ramdac"
[   641.969] (II) Module "ramdac" already built-in
[   641.970] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   641.970] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   641.970] (==) NVIDIA(0): RGB weight 888
[   641.970] (==) NVIDIA(0): Default visual is TrueColor
[   641.971] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   641.971] (**) NVIDIA(0): Enabling 2D acceleration
[   644.031] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[   644.031] (--) NVIDIA(0):     DFP-0
[   644.031] (--) NVIDIA(0):     DFP-1
[   644.031] (--) NVIDIA(0):     DFP-2
[   644.032] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 1070 (GP104-A) at PCI:1:0:0 (GPU-0)
[   644.032] (--) NVIDIA(0): Memory: 8388608 kBytes
[   644.032] (--) NVIDIA(0): VideoBIOS: 86.04.33.00.04
[   644.032] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   644.033] (--) NVIDIA(GPU-0): DFP-0: disconnected
[   644.033] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[   644.033] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[   644.033] (--) NVIDIA(GPU-0):
[   644.033] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   644.033] (--) NVIDIA(GPU-0): DFP-1: Internal DisplayPort
[   644.033] (--) NVIDIA(GPU-0): DFP-1: 960.0 MHz maximum pixel clock
[   644.033] (--) NVIDIA(GPU-0):
[   644.034] (--) NVIDIA(GPU-0): DFP-2: disconnected
[   644.034] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[   644.034] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[   644.034] (--) NVIDIA(GPU-0):
[   644.034] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0.
[   644.034] (EE) NVIDIA(0):     Set AllowEmptyInitialConfiguration if you want the server
[   644.034] (EE) NVIDIA(0):     to start anyway
[   644.034] (EE) NVIDIA(0): Failing initialization of X screen 0
[   644.306] (II) UnloadModule: "nvidia"
[   644.306] (II) UnloadSubModule: "wfb"
[   644.306] (II) UnloadSubModule: "fb"
[   644.306] (EE) Screen(s) found, but none have a usable configuration.
[   644.306] (EE)
Fatal server error:
[   644.306] (EE) no screens found(EE)
[   644.306] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   644.306] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   644.306] (EE)
[   644.328] (EE) Server terminated with error (1). Closing log file.
 
Back
Top