Nvidia hdaudio quirks

ChickenWing88

Member


Messages: 24

I have just finished installing freebsd 7.1 on a Hp Pavilion a6230n with the following HD audio Card.

Code:
hdaudio0: [ITHREAD]
hdaudio0: <nVidia HD Audio> mem 0xfe024000-0xfe027fff irq 23 at device 5.0 on pc

However when ever i ttry to use this HD Audion device I get a high pitched wine in my Spwakers. Does any one know How to fix this?

Expeditious answers are much nnede and apreciated.
 

randux

Active Member

Reaction score: 4
Messages: 131

did you try other devices like headphones, etc. Computers are harsh environments for RF and audio. If you get interference with other output devices you might try a noise suppressor on the cables before concluding the card is bad or doesn't work properly.

I had a set of headphones and a mic that buzzed and hummed on two separate lappies. It was so bad I thought I wasted my money completely. On a 3rd box it's a joy to use.
 

plamaiziere

Active Member

Reaction score: 40
Messages: 184

ChickenWing88 said:
I have just finished installing freebsd 7.1 on a Hp Pavilion a6230n with the following HD audio Card.

Code:
hdaudio0: [ITHREAD]
hdaudio0: <nVidia HD Audio> mem 0xfe024000-0xfe027fff irq 23 at device 5.0 on pc

However when ever i ttry to use this HD Audion device I get a high pitched wine in my Spwakers. Does any one know How to fix this?

There was a major update of snd_hda in 7 STABLE, you can try it or just use the version of CURRENT.
Just get the files in /usr/src/sys/dev/sound/pci/hda and rebuild the module.

Hope this help.
 
Top