Nvidia drivers

I've just installed FreeBSD 10.2 on a Thinkpad T61 which uses an Nvidia graphics chip. There seem to be a few different Nvidia drivers around. How do I tell if I have to correct one installed?
Is there any benchmarking I can do on the system? I'm using Xfce and it seems a little choppy.. Debian, on the same machine appears to be much smoother.
Before you install the nvidia-driver make a directory /compat/linux/proc. Write in /etc/fstab
linprocfs  /compat/linux/proc linprocfs  rw  0  0
and run kldload linux.
Also add to /etc/rc.conf
and to
Thanks to everyone for their help, I would never have stumbled on how to get this working - I'll see if I've managed after rebooting. After the installation I got this info:

Message from nvidia-driver-340-340.93:
To use these drivers, make sure that you have loaded the NVidia kernel
module, by doing

    # kldload nvidia

or adding


to your /boot/loader.conf.

If you build this port with FreeBSD AGP GART driver, make sure you have
agp.ko kernel module installed and loaded, since nvidia.ko will depend
on it, or have your kernel compiled with "device agp".  Otherwise, the
NVidia kernel module will not load.  Also, please set correct value for
``Option "NvAGP"'' in ``Device'' section of your X11 configuration file.

When building with Linux compatibility support, make sure that linux.ko
module is available as well (or have it compiled in kernel).  It can be
loaded via /boot/loader.conf, or later in the boot process if you add


to your /etc/rc.conf.

If X.org cannot start and reports

    (EE) NVIDIA(0): Failed to obtain a shared memory identifier.

in /var/log/Xorg.0.log while actually you have ``options SYSVSHM''
enabled in kernel, the sysctl ``kern.ipc.shmall'' should be increased.

See /usr/local/share/doc/NVIDIA_GLX-1.0/README for more information.
Yes, forgot you have to add
to /boot/loader.conf.

If you don't want reboot, you have to run kldload nvidia.
Yes, forgor you have to add
to /boot/loader.conf.

If you don't want reboot, you have to run kldload nvidia.
A better suggestion, noted in tobik's thread he added in his reply above, is to add kld_list+=nvidia to /etc/rc.conf instead by running sysrc kld_list+=nvidia. It's more reliable.
I've just rebooted and things are much better now. Thanks to everyone who helped.

Also I am now able to run vidcontrol whereas I was unable to before...