nvidia-driver on 11.0 BETA3

Not strictly an Xorg problem, I'm testing FreeBSD 11.0-BETA-3 and now have a couple extra issues with the nvidia drivers that I'm finding difficult to figure out. This is on a MacbookPro5,1 which has an nVidia GeForce 9400M and 9600GT.

On 10.3-RELEASE I could get only the 9400M to work with both nvidia-driver-340 and nvidia-driver-304 port. (The other gave a black screen)

On 11.0-BETA3 I can only get the 9600GT to work and only on the nvidia-driver-304 port. Additionally the kernel module refuses to load at boot or in rc but will manually load without issue.

I know the nvidia drivers are closed source and have many problems, so i'm not expecting to get it working perfectly. However the kernel module not loading at boot is particularly annoying. I've tried find out how to look into issues during the boot stage and tried enabling console.log and looking through dmesg... but I cannot find any errors regarding that module.

Am I looking in the right place? what else can I do to debug kernel module problems at the boot stage?
Don't use the package, build it from ports. The NVidia kernel module needs to match the exact kernel version (also make sure /usr/src/ is correct for your system) or else it'll fail to load.
Thanks SirDice I was not aware of that, i'll try building it.

Strange that it works if I load it manually then. I wonder if this is a safety feature for automatically loading potentially incompatible kernel modules?

You may have more luck on freebsd-current: https://forums.freebsd.org/threads/40469/

Thanks, I understand I probably will have more luck on CURRENT. I just wanted to prepare for the release of 11 and figure out if this was an incompatibility, a bug or just my ignorance... looks likely to be to be the later (fingers crossed :p).
Ok, so the version is probably correct or else it would have failed to load manually too. I'm assuming you did kldload nvidia? Are there any messages in /var/log/messages that shows it loaded correctly and detected your card?
Yes, it loads correctly with kldload and it works... or at least the nvidia-driver-304 does, but i'm not picky.

I just cant figure out why it doesn't automatically load if i put it in the loader.conf and rc.conf. I've tried this on a fresh install with nothing else and it makes no difference.

I've used nvidia_load and nvidia_enable variables the same as I have in previous systems and I double checked the port message incase this had changed. Other modules I put in loader.conf load fine.


just so i'm clear that I believe there is no error here:

Try adding this to /boot/loader.conf:
Hopefully that provides a bit more information.
:) thanks, that's the sort of thing I was looking for, and just to confirm: dmesg or console logging will capture this output? (i'm suspicious because it's very quiet regarding video cards currently)