Running vidmode -i mode gives a list of 511 "empty" modes mostly zero's and all identical.

I have 10.3-stable generic kernel, have installed nvidia driver for GTX 750 TI with three heads. Though it might only see two.

The computer is a Supermicro (gen 8) with two quad cores and 32G RAM.
Being totally new to FreeBSD I've been working my way through the forums and docs with the end goal of getting KDE up and running.

Nvidia driver is loaded as is linux 32 & 64 bit binary compat kernel modules, I installed and ran nvidia-xconfig which generates a config file for both Radeon & Nvidia. I removed the Radeon "Device" config and when I fire up startx it goes into some video mode which totally black. Exiting left it in an odd mode with simply some color bars here and there. BTW, I also have the new vt driver loaded.

When running startx -config ~/ (as root) the Xorg.log file reports it sees more than one possible primary device, but it loads GLX and nvidia unified driver, so is fb, wfb, ramdac, enables 2D acceleration, recognizes all three monitors, sees that it adds up to 5760x1200 pix, 24bit depth, dri2 is loaded, RandR is disabled, probes and finds the keyboard, mouse and then shows the monitors again. Successful termination. Not a single error.

I walked away to get busy with other things.

Then came back and rebooted out of it and when I tried to run it again it came back with no screens found. xinit complained that the connection was refused, server error, and that the display name is bad which is the same as the hostname:0. sounds like I loaded something and it's not configured on boot.

kldstat reports nvidia, linux, uhid and ums is loaded. (Including zfs, Opensolaris and the kernel.)

I really don't know enough here and though I tried to stick to pkg all over I may have compiled a source someplace, like nvidia. Not sure. You guys could probably tell.
I ended up reinstalling with the new version that had just come out and everything worked.