No WiFi on fresh FreeBSD install.

Just installed and booted FreeBSD on a 64 gig sd on my HP 11A G8 EE chromebook

Need help configuring network
already tried a bunch of things but they won't work!
Hello & Welcome to the FreeBSD community!

What did you try? What problems did you encounter? Which WiFi card is installed in the machine? Did you read the corresponding chapter of the handbook?
If in doubt, show us the output of pciconf -lv and usbconf (please be sure to wrap the output into [cmd][/cmd] when posting it here.

As a (side) note: Wireless on FreeBSD is bit of a mood point. Don't expect the same level of compatibility & performance as with other operating systems. However, the FreeBSD foundation is currently funding work for WiFi 5 support.
Browser be acting weird
this isnt literally a copy paste but
vendor = Qualcomm atheros
device = QCA6174.11ac Wireless Network Adapter
class = network

I tried different things but thing is I was mostly copy pasting everything I found online
Most problematic can be integrated accelerated video cards.
As wifi can always be fixed using the cheapest usb dongle, even if this is not the most beautiful solution.
If you need a GUI-based Wi-Fi manager for a desktop environment, try networkmgr or wifimgr. For console-based devices, try the bsdconfig wireless command, but I have never been able to get it to work properly on my laptop, so I just set each hotspot up by hand.

To identify your WiFi hardware:

$ su

# sysctl net.wlan.devices
net.wlan.devices: iwn0

# pciconf -lv | grep -B3 network
iwn0@pci0:3:0:0:    class=0x028000 rev=0x34 hdr=0x00 vendor=0x8086 device=0x0085 subvendor=0x8086 subdevice=0x1311
    vendor     = 'Intel Corporation'
    device     = 'Centrino Advanced-N 6205 [Taylor Peak]'
    class      = network

# apropos intel | grep wireless
iwm, if_iwm(4) - Intel IEEE 802.11ac wireless network driver
iwn, if_iwn(4) - Intel IEEE 802.11n wireless network driver

# man iwn

If your device is not recognized, try a USB WiFi dongle instead. Supported hardware appears in the release notes under the section Wireless Network Interfaces. Once the hardware is recognized, add 2 lines to /etc/rc.conf to configure the drivers for that device (iwn0 in this case):

# cat /etc/rc.conf
ifconfig_wlan0="WPA SYNCDHCP"

Finally, use wpa_passphrase >> to add the SSID and passphrase to /etc/wpa_supplicant.conf for the hotspot.

# wpa_passphrase "SSID" "WPA2passphrase" >> /etc/wpa_supplicant.conf

# cat /etc/wpa_supplicant.conf

Restart the network service and ping something to check:

# service netif restart

# ifconfig
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 8c:70:5a:bd:39:3c
        inet netmask 0xffffff00 broadcast
        groups: wlan
        ssid SSID channel 2 (2417 MHz 11g ht/20) bssid 1c:af:f7:dd:9c:3b

# ping


For the ac aspect, I guess, see:

The project page lacks a link to the wiki page through which progress is summarised: