• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved No internet connection with my wireless card!

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#1
Hello!
My name is Staffan Mattsson and Im sort of new to freebsd. Ive seen the maskot a little bit here and there, and wondered what it was. As Im a little bit curious I want to set up a desktop with a c64 emulator where I can play "Sams journey". Yes I pick that as a challenge. Play Sams Journey.

I will of course stop when you tell me this is impossible. :)

My first problem is to connect my wireless card. It is now selected and apperantly freebsd calls my card ath0. When I boot up it detects the network, but running ifcongig shows that authmode is open which is wrong, and im not connected.
However, when I run wpa_supplcant I can ping googles dns server at 8.8.8.8, but I want it to work at boot time.

Later problems would be: Getting Sound, XFCE,NVIDIA graphics and C64 emulator to work.
My NVIDIA flickers on all Linux distributins until I install a third party driver, so this worries me alot.

my rc.conf:
blablabla...
ifconfig_wlan0="WPA DCHP"
ipconfig_wlan0="ssid ASUS_40_2G DHCP"

Perhaps it should be "WPA-PSK DCHP" first?
please help....

Also wish I had a real reason to run this OS...
/Staffan
 

Attachments

sidetone

Aspiring Daemon

Thanks: 220
Messages: 778

#2
There's no ipconfig here.
Code:
ifconfig_wlan0="WPA DCHP"
ipconfig_wlan0="ssid ASUS_40_2G DHCP"
Its supposed to be
Code:
wlans_ath0=wlan0
ifconfig_wlan0="WPA DHCP ssid yourssid"
You can add more arguments like bssid, so it will connect easier.

wpa_supplicant.conf(5), rc.conf(5), ifconfig(8). Also, look in the FreeBSD handbook.

In wpa_supplicant.conf, RSN refers to WPA2. Find the options for PSK there as well.

I'm not sure if ifconfig_ath0="WPA DHCP ssid yourssid" without the group and wlans will work too.

* Edit - wlans_ or other argument for wireless or other special drivers is needed in ifconfig. A wired connection can directly use the card driver Like
Code:
ifconfig_re0="DHCP" # replace re0 with your driver
.
 
Last edited:

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#3
This works! Thank you! :)
However I did put some efforts into reading the handbook and still didnt figure this out. That worries me.
I never wrote ipconfig the file sad ifconfig, this was just a typo. Just wanted to say that. :)

This made me very glad, but a new problem arise! The system wants to send some kind of mail in the beginning, which slows down boot time.
https://forums.freebsd.org/threads/1804/ is a thread where this is handled.

appearantly you could do this:
sendmail_enable="NONE"
sendmail_msp_queue_enable="NO"
sendmail_outbound_enable="NO"
sendmail_submit_enable="NO"
I get the impressing in the thread that this is cheating however, and the thing you should do is to add a hostname to /etc/hosts
I have no clue what to write there as Im not trying to do a server...
right now it says:

::1 localhost localhost.my.domain
127.0.0.1

I would really appreciate if you could help me with this and all other listed stuff above when I get to it. Dont spend too much time though, as Im rather unserious with this freebsd project as you might have noticed :) Even so my thankfullnes and fascination for you guys is real!
Lets see if the community is as friendly as they say :)
 

sidetone

Aspiring Daemon

Thanks: 220
Messages: 778

#4
Code:
sendmail_enable="NONE"
should take care of all of sendmail.

You can also block the sendmail's ports with pf.conf(5), which takes a lot of learning, and disabling sendmail's installation in src.conf(5) for buildworld. That's a project for later.

I'm not good with /etc/hosts.conf and dns. Keep using man pages, and searching for them with man -k and |grep.
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#5
Thanks again! That worked as well. Still far from my goal though.

No to a more serious problem. I cannot install my nvidia driver. If I get the handbook right, i should use nvidia-driver-340 bevause their homepage says so.
When I try "pkg install nvidia-driver-340" it doesnt install because it requires Linux compatibility my core doesnt have.
I try instead to go to ports/x11/nvidia and try make install without the linux compatibility option. then it says it requires source code in usr/src....
when I try to download code from git my cpu gets to hot on this old laptop and shutsdown at 27%.... :(

I have reason to believe this could be the fault to why I get the "No screen available" when I type startx. The log file says something like no device like Nvidia available.

Is this even possible to solve? I dont have room for the entire kernel source on this laptop. I thought it should be something like 5mb.... but obviously I learned somehing here.
 

Maxnix

Well-Known Member

Thanks: 139
Messages: 251

#6

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#7
Thanks Maxnix! I didnt knew you could do that without compiling the source and make a new kernel. Thats why I didnt search for it in the handbook.
I just realised that learning freebsd is not about learning how to do stuff in your head, but rather know what it can do, and what you want to do, so that you can look for it in the right place.

I can now install the NVIDIA-DRIVER-340 package. Al ot of important text came upp after installation, but I accidently pushed it away. (have Children home)
However when I type startx it doesnt work and my log now looks the same as in this thread:
https://forums.freebsd.org/threads/61062/
at least during the "ee" parts.

No device found. Before the package install it said no nvidia found. I will try some stuff from this thread when I get home. But that doesnt mean I dont welcome other Ideas here too :)
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#8
Still doesnt work, and now Im out on ideas. Still the log file looks almost identical to the one in the above thread.
Kldstat shows nvidia.ko is loaded.

Both lines nvidia load and nvidia modesetload is present in loader.conf
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#9
Please ignore the above post. Unexpexted progress happend. I can now reach something that looks like a graphical login every time I reboot the machine, even though I didnt even type startx. I can even see the nvidia logo before :) This made my day!!!

The login square take up almost the entire screen though and it doesnt look like xfce from linux which I tried to install with the handbook...
When I try to login it just goes back to let me login again.... In the lower right corner there is something that says consolelog for staffan.
WEIRD!
Please help.
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#10
Ok. I noticed that root cannot login and that I typed my user with small capital...

Now I can login to a desktop environment that has three terminals up and running. But this is not xfce? Why didnt xfce came up. I followed the handbook and wrote startxfce4 in xinitrc.
 

OJ

Daemon

Thanks: 243
Messages: 1,024

#11
Now I can login to a desktop environment that has three terminals up and running.
This is what Xorg looks like on it's own. You normally don't see it, but it is what xfce and others run on. So anyway, at least you have X running OK. :) Did you actually install xfce?
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#12
Yes! I typed in "pkg install xfce" again just to be sure, but then he said that all the packages where up to date. So Yeah :) I think so, but can never be sure.

my .xinitrc file only have theree lines where one is "exec /usr/local/bin/startxfce4 --with-ck-launch" and I dont rememeber the other two since Im at work right now :)

I also didnt bother doing anything on this page: https://www.freebsd.org/doc/handbook/x-compiz-fusion.html
Dont know if it is important, but I thought I should mention it.
 

CraigHB

Member

Thanks: 24
Messages: 93

#13
There's a note in the man page about setting up the xinitrc file and how commands have to be organized. The last line should be your window manager which is going to be the anchor application (doesn't have to be). The anchor program is the one that shuts down X when closed. That should run in the foreground. Any other programs must be listed before the anchor and started in the background by ending the line with an ampersand. Not sure if that's your problem, but without seeing your xinitrc its a reasonable guess.
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#14
I think Im way off here...
Now I cannot even log in with my user anymore. And I dont think Ive changed anything.

Ive tried "man xinitrc" but gets "No manual entry for xinitrc." Ive tried "man man" to see

I also thought that .xinitrc should be in root/.xinitrc or in usr/Home/Staffan/.xinitrc but apperantly it is in usr/lokal/etc/X11/xinit/xinitrc

I found this out on a forum and not in the handbook. Am I Reading the handbook wrong somehow? It just said to Echo "exec /usr/local/bin/startxfce4 --with-ck-launch. That made me create a .xinitrc file in that location with just one line.

The Newly found xinitrc in usr/local/etc/X11/xinit/xinitrc ends with: exec xterm - geometry bl.a. Bl.a.
I tried putting exec bl.a. Bl.a. Startxfce4 there but it didnt work.
Looks dark now this hobbyprojekt :(
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#15
Ok I disabled to start xdm automaticly. That was what was causing the strange loginbox to appear. I read this in the handbook and just did it without knowing the actual result. ☺ thats why I didnt have to type startx. Now it looks better, but xfce doesnt start when I type startx, becsuse the screen is already being used by device 0, which is a lie... I did just reboot the computer and still get this message.
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#16
I now know that he is using my users xinitrc file in usr/home/Staffan/.xinitrc because he complained about a spelling error there that I corrected....
that xinitrc file is created by me and only has the now famous startxfce line in it.

The question is still why there is a xinitrc file with several rows in /usr/local/etc/X11/Xinit that not made by me....

Now I get "Xserver already running on display 0." Which make no sense since it was a cold restart..

I can still see the NVIDIA logo at start and thats whats keep me going :)

I know you get a bunchful of new users asking stuff of course... cannot be fun when you want intelligent questions such as "Why is FAT32 better than ZFS?" and so on.
Im not good at ansering forum questions either... so I cannot blame you.

Please Help!
 

Staffan Mattsson

Member

Thanks: 1
Messages: 28

#17
After a talk with Admin I mark this as solved since the network problem is solved. I will start a new thread with trying to get XFCE to work.
(I asked him how he wanted to handle a thread like this in the forum.)