Solved NFSv4, How to activate 'server-side copy' feature?

Hello :),

I've tested my FreeBSD-Server with NFSv4-Daemon (Quadcore, 32GB RAM, 250GB SSD L2ARC, 6 HDDs RAID-Z2, 1 Gbps NIC), because I recognized that a file copy (40 GB) from an NFSv4-Client needs a lot of time.

For example:
dd if=/dev/zero of=testfile bs=1G count=50

--> running on Client NFSv4-share: 110 MB/s
--> running directly on the server: 1100 MB/s

I'm not sure, if the NFSv4-Feature server-side copy is enabled by default.


Does anybody know, how to check this feature or how to activate this feature/ speed up the process?

Thank you.

#mount -l /home on /home type nfs4 (rw,relatime,vers=4.0,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,
As far as I've been able to figure out it is a suggested feature for NFS 4.2 (which is still being developed).
You need a faster NIC if you want to go above 110 Megabyte per second.

1GBit/s /8 = 125 MB/s theoretical maximum
Not exactly relevant. The idea behind 'server-side copy' is that files copied within the NFS share aren't pulled over the network. The copy action takes place entirely server-side.
Indeed, you're correct about that. I was just wondering the same thing really.
Well you could be right too. Maybe it was only the way he created the testfile.
We need to know what he is exactly doing. :)
You are right. It was the wrong command to test it, because it was no copy-process (only a file creation). In this case the 1 Gbps NIC was the bottleneck.

Now i tried to move a big 40 GB file from one mounted nfs-share to another mounted nfs-share (both shares are from the same server). The NIC-Interface is saturated (nearly 1 Gbps) and the copy process is slow, around 35-40 MB/s. So it seems, that there is no server-side copy active. I think, that the client receives the file from one nfs-share and then sends it back to the other nfs-share (~ 80 MB/s duplex, only for file data).

edit: has anybody an idea, how to check the running nfsd version?
Thank you, interesting urls :)

pNFS is new for me. Now i have to study a little bit ;)

edit: solved (where is the button to mark the thread? o_O)