• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

NFS exports faulty

Marco2G

New Member


Messages: 9

#1
Hi everyone

I am having issues with some NFS exports. They have worked up to a few hours ago and upon a reboot (but not the first today) they stopped working. On the client side I receive access denied messages. When looking into /var/log/system.log, I can see that my ESXi host is logged as requesting /usr/storage/nas/ISOs, for example, however the export is just /storage/nas/ISOs.

I get the following errors that I find pertinent:
Code:
mountd[3052]: bad exports list line /storage/nas/ISOs
mountd[3053]: mount request denied from 192.168.2.100 for /usr/storage/nas/ISOs
exports.JPG


The exports list is empty but all the services seem to be running if rpcinfo is to be believed. I also don't get any errors when restarting mountd, nfsd, lockd and statd.

Does anyone have any idea what might be the issue?

Thank you!

Marco
 

phoenix

Administrator
Staff member
Administrator
Moderator

Thanks: 1,038
Messages: 3,828

#2
You can only have 1 line per client IP address/subnet. You have separate lines for /storage/nas/Media and /storage/nas/ISOs allowed for 192.168.2.100. Just put both paths onto the same line:
Code:
/storage/nas/Media /storage/nas/ISOs -ro -mapall=root -network 192.168.2.0 -mask 255.255.255.0
Same for your two lines with 192.168.2.100 in it.
 

Marco2G

New Member


Messages: 9

#3
Thank you for your input but that does not seem to be the reason. First, it has been like this for weeks and it worked.

Second, I tried starting over and now I have only two lines in export, with different clients. Even at only one line it did not work.
 

Marco2G

New Member


Messages: 9

#4
Upon reinstalling a few times, I noticed that this occurs when I setup NFS and then changed the hostname. If I change the hostname first, everything keeps working fine.