nfs client cannot connect

leveraction

Member

Reaction score: 2
Messages: 35

I have a freebsd nfs server that has worked happily for years on my local office network. It still does. That same server runs samba and several others that I can access from my home LAN across a vpn. In fact, the server works great except for one thing. I cannot use nfs to mount directories from the server to a workstation in the home LAN over the vpn even though it works great on work stations at the office LAN. The freebsd server has no firewall and the two sonicwalls on either side of the vpn deny no traffic. When I attempt to mount a directory on the home work station it times out. Both home and office workstations are ubuntu 20.04. The logs on the home workstation report the following:

nfs_create_rpc_client: cannot create RPC client. Error = -22

If I run:
Code:
rpcinfo -p <ip address>
I get:
<ip address>: RPC: Remote system error - Connection refused

I have googled this quite a bit and have not been able to figure it out. What am I missing?
 
Top