1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New nVidia AMD64 drivers - please, share your experience !

Discussion in 'System Hardware' started by Unixworld, Dec 7, 2009.

  1. Unixworld

    Unixworld New Member

    Thanks Received:
    Hello, lads !

    I'd like to start a new "high graphics usage/HD-torture/gaming
    thread :)" for all of us to share experience, difficulties, headaches, and of course - knowledge :stud !
    I did see there was already a thread open, from a guy with a certain problem, but i just didn't want to "dilute" the guy's
    specific theme with this one.
    May the mods forgive me, if i have chosen the wrong place,
    and move this to a more appropriate nest;)

    Well, my first experience besides the KDE4-environment, which
    seems to work well with the current 195.22-beta driver, is gaming with old-school "classic" games - RTCW.
    I'm pretty sure, most will agree, such games are really CULT,
    and that they just must exist for any possible platform !
    Just before my switch to AMD64 (again, just after i knew a driver had been released), the game worked just fine under the i386 brand of FreeBSD 8.0-RELEASE.
    Not this time, here's what's goin' on by me :

    $ wolfsp              
    Wolf 1.41 linux-i386 Dec  4 2002
    ----- FS_Startup -----          
    Current search path:            
    /usr/local/share/rtcw/main/sp_pak3.pk3 (14 files)
    /usr/local/share/rtcw/main/sp_pak2.pk3 (232 files)
    /usr/local/share/rtcw/main/sp_pak1.pk3 (1342 files)
    /usr/local/share/rtcw/main/pak0.pk3 (4775 files)   
    6363 files in pk3 files
    execing default.cfg    
    couldn't exec language.cfg
    couldn't exec wolfconfig.cfg
    couldn't exec autoexec.cfg  
    Hunk_Clear: reset the hunk ok
    Bypassing CD checks          
    ----- Client Initialization -----
    Cmd_AddCommand: map_restart already defined
    ----- Initializing Renderer ----           
    ----- Client Initialization Complete -----
    ----- R_Init -----
    ...loading libGL.so.1: Initializing OpenGL display
    ...setting mode 3: 640 480
    Using XFree86-VidModeExtension Version 2.2
    XF86DGA Mouse (Version 2.0) initialized
    XFree86-VidModeExtension Activated at 640x480
    Using 8/8/8 Color bits, 24 depth, 0 stencil display.
    Initializing OpenGL extensions
    ...using GL_S3_s3tc
    ...ignoring GL_EXT_texture_env_add
    ...using GL_ARB_multitexture
    ...using GL_EXT_compiled_vertex_array
    ...using GL_NV_fog_distance
    XF86 Gamma extension initialized
    GL_VENDOR: NVIDIA Corporation
    GL_VERSION: 3.2.0 NVIDIA 195.22
    GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_compatibility GL_ARB_copy_buffer GL_ARB_depth_buffer_float GL_ARB_depth_clamp 
    GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_coord_conventions 
    GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB 
    GL_ARB_geometry_shader4 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_map_buffer_range GL_ARB_multisample 
    GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex 
    GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp 
    GL_ARB_texture_buffer_object GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add 
    GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat 
    GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix 
    GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program 
    GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add 
    GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate 
    GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access 
    GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample 
    GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters 
    GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object 
    GL_EXT_point_parameters GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_shader_objects 
    GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array 
    GL_EXT_texture_buffer_object GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc 
    GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic 
    GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object 
    GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback2 GL_EXT_vertex_array 
    GL_EXT_vertex_array_bgra GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_conditional_render 
    GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float GL_NV_depth_clamp GL_NV_explicit_multisample GL_NV_fence 
    GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 
    GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_gpu_program4 GL_NV_half_float GL_NV_light_max_exponent 
    GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object 
    GL_NV_parameter_buffer_object2 GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners 
    GL_NV_register_combiners2 GL_NV_shader_buffer_load GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc 
    GL_NV_texture_env_combine4 GL_NV_texture_expand_normal GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 
    GL_NV_texture_shader3 GL_NV_transform_feedback GL_NV_transform_feedback2 GL_NV_vertex_array_range GL_NV_vertex_array_range2 
    GL_NV_vertex_buffer_unified_memory GL_NV_vertex_program GL_NV_vertex_
    Received signal 11, exiting...

    Dunno if this one should yield smth, like in linux, but i tried
    it nonetheless, and it is odd :
    $ glxinfo | grep rendering
    glxinfo: not found

    The modules loads and works fine, otherwise :
    $ kldstat
    Id Refs Address            Size     Name
     1   47 0xffffffff80100000 d17dc0   kernel
     2    1 0xffffffff80e18000 3f18     ng_ether.ko
     3    4 0xffffffff80e1c000 14e10    netgraph.ko
     4    2 0xffffffff80e31000 75708    sound.ko
     5    1 0xffffffff80ea7000 23ed0    snd_hda.ko
     6    1 0xffffffff80ecb000 d3cac8   nvidia.ko
     7    3 0xffffffff81c08000 413b0    linux.ko
     8    1 0xffffffff81c4a000 9840     udf.ko
     9    1 0xffffffff81c54000 52d0     atapicam.ko
    10    1 0xffffffff81c5a000 1060     cd9660_iconv.ko
    11    2 0xffffffff81c5c000 6cc8     libiconv.ko
    12    1 0xffffffff81e22000 3a28     linprocfs.ko
    13    1 0xffffffff81e26000 323e     ng_pppoe.ko
    14    1 0xffffffff81e2a000 1a52     ng_socket.ko
    15    1 0xffffffff81e2c000 a1d1     ipfw.ko
    16    1 0xffffffff81e37000 a8ca     fuse.ko

    All necessary linux stuff (to my knowledge)00 is there, too :
    $ pkg_version -v | grep "linux"
    linux-dri-7.4_1                     =   up-to-date with port
    linux-f10-atk-1.24.0                =   up-to-date with port
    linux-f10-cairo-1.8.0               =   up-to-date with port
    linux-f10-curl-7.19.6               =   up-to-date with port
    linux-f10-cyrus-sasl2-2.1.22        =   up-to-date with port
    linux-f10-expat-2.0.1               =   up-to-date with port
    linux-f10-flashplugin-10.0r32       =   up-to-date with port
    linux-f10-fontconfig-2.6.0          =   up-to-date with port
    linux-f10-gtk2-2.14.7               =   up-to-date with port
    linux-f10-jpeg-6b                   =   up-to-date with port
    linux-f10-libssh2-0.18              =   up-to-date with port
    linux-f10-nspr-4.7.6                =   up-to-date with port
    linux-f10-nss-              =   up-to-date with port
    linux-f10-openldap-2.4.12_1         =   up-to-date with port
    linux-f10-openssl-0.9.8g            =   up-to-date with port
    linux-f10-pango-1.22.3              =   up-to-date with port
    linux-f10-png-1.2.37                =   up-to-date with port
    linux-f10-sqlite3-3.5.9_1           =   up-to-date with port
    linux-f10-tiff-3.8.2                =   up-to-date with port
    linux-f10-xorg-libs-7.4_1           =   up-to-date with port
    linux-quake3-1.32c                  =   up-to-date with port
    linux_base-f10-10_2                 =   up-to-date with port
    linuxdcpp-1.0.3_1                   =   up-to-date with port


    Odd thingies... I start suspecting the driver itself, because
    to my FreeBSD-newbie knowledge - everything that might cause
    troubles otherwise is in its place, reinstalling the driver/dri*/the game didn't help either...

    Has someone tried playing HD/heavy gaming with the new driver? Please, share your experience !

    Thanx all in advance !

  2. ericturgeon

    ericturgeon Member

    Thanks Received:
    To me all work great and i can play Sauerbraten on full resolution and all graphics setting at max no lag but to warm I need to put fan on it to play game. my machine its a amd 6000+ processor. Plus my new graphic card G92 ASUS 9600 GSO, 2GB of ram on a ECS GeForce7050M-M motherboard With FreeBSD amd64. For the time I buy some fan. I open my case and I put a turbo fan by side my desktop. Its work great.
  3. Giorgos

    Giorgos New Member

    Thanks Received:
    same problem here, although i have installed the new nvidia driver and load it in the kernel when i enter glxinfo i get the same result as you. I have a GeForce 8400M GS.
  4. hermes

    hermes New Member

    Thanks Received:
    @Giorgos: That’s expectable, because there is no glxinfo in FreeBSD like in Linux. No need to worry. You may wish to install graphics/mesa-demos for testing 3D.

    @Unixworld: Signal 11 is pretty unspecific; if you think it’s worth it, you might want to compile RTCW with debug symbols and run it from gdb. I wouldn’t get my hopes up though.
  5. ehwood

    ehwood New Member

    Thanks Received:
    Of all the things I've had to muck around trying to set up on FreeBSD 8 on my own AMD64 system, the nvidia driver has proven one of the easiest. As I recall, I got it from nvidia's site (following an online search) and just followed directions to have my Xorg using the new driver.

    I haven't been able to test it with anything terribly demanding so far, but Warzone2100 runs like a champ, as does ppracer. The hardware is a PCIe PNY Geforce 8600 GT w/ 256 MB. I think it's a more solid performer with this system than it was with Fedora or Ubuntu.
  6. tankist02

    tankist02 Member

    Thanks Received:
    G96 [Quadro FX 380]
    8.0 p2 Release amd64,
    xorg.conf generated by Xorg -configure

    X starts fine, but hangs on exit. Disabling Composite doesn't help.
  7. donald1000

    donald1000 New Member

    Thanks Received:
    The new driver is so great. FreeBSD 7.3-STABLE AMD64, GeForce 9800 GT, driver version 195.36.24.

    I've got a dual head monitor config. Glexcess demo plays perfect, quake3 and all KDE3 openGL screensavers work fine :) All the developers have done a great job.

    Best regards
  8. blak3mill3r

    blak3mill3r New Member

    Thanks Received:
    random x crashes with NVIDIA-FreeBSD-x86_64-195.36.15

    I just installed the latest driver, and I'm getting random x crashes. :( Haven't poked around at it much yet, but it is definitely driver related. It's quite unpredictable, sometimes X will run okay for a few minutes (but not for much longer than that).

    Only Xorg crashes, the kernel is fine. I'm hoping to read sth good on the subject, otherwise I'll get a backtrace and go from there ... I'll post back here if/when I figure out anything interesting.

    My hardware is a GTX295 PCI-e with a core i7.
    using FreeBSD 8.0-release with GENERIC kernel (fresh install, today)
    dual head

    Anyone have this driver working with a GTX2** card or newer? Anyone experiencing frequent random crashes?

    I'm not sure if there's anything "special" about the nvidia-driver port ... but I tried that as well, after manually installing the package from nvidia.com, no luck.

    I am hopeful! I really don't want to switch back to x86 or use an open source driver.

    Cheers :beer
  9. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Thanks Received:
  10. blak3mill3r

    blak3mill3r New Member

    Thanks Received:
    got it working

    FWIW do not use xinerama extension ... you want twinview or separate X screens anyway and that was the source of my crashes (narrowed it down carefully)