New Monitor Resoution problem

Woops. It looks like the log is bad now. I've messed around enough to bung it up again. I'll get the log back to were it was then try to post again
 
Virtual screen size determined to be 2560 x 1080...

It looks correct but still looks bad
 
It's not the resolution

xrandr
Code:
Screen 0: minimum 8 x 8, current 2560 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected primary (normal left inverted right x axis y axis)
DVI-I-1 connected 2560x1080+0+0 (normal left inverted right x axis y axis) 798mm x 334mm
2560x1080 60.00*+
1920x1080 60.00
1680x1050 59.95
1600x900 60.00
1280x1024 75.02 60.02
1280x720 60.00
1152x864 75.00
1024x768 75.03 60.00
800x600 75.00 60.32
640x480 75.00 59.94
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)

but it still looks horrible. I couldn't even read this on the screen
 
Sorry bout that

2016-07-03-165520_2560x1080_scrot.png
 
That's because it's a screen shot, which skips the physical display layer in xorg. A photo might give us a better idea what the issue is.

One random stab in the dark: If resolution is correct but text is illegible then it could be sub-pixel antialiasing modes... (there are multiple orders and arrangement of the R,G,B sub-pixel components) if you have one of the less common arrangements and it's not auto detected or not correctly detected (especially when the output is not DVI) then subpixel antialiasing can make stuff look real nasty.
 
tomxor Thank YOU. That might be it.

Sorry for the late reply but here are the pics. They're not great but I think you can see the issue.
 

Attachments

  • IMG_20160704_122414.jpg
    IMG_20160704_122414.jpg
    573.2 KB · Views: 495
  • IMG_20160704_122422.jpg
    IMG_20160704_122422.jpg
    977 KB · Views: 397
  • IMG_20160704_122428.jpg
    IMG_20160704_122428.jpg
    905.2 KB · Views: 420
Another possibility may be the DPI. I noticed that yours is 80, 81 and mine is 95, 94. I too have an NVIDIA video card (GT 610), but my monitor is at 1920x1080 connected via HDMI and I don't have any font issues. Depending on your desktop environment, there may be a GUI to force the DPI and font sub-pixel anti-aliasing modes. You can also configure the DPI in the xorg.conf file as well. The sub-pixel anti-aliasing modes can be configured through the fontconfig configuration files.
 
Definitely a font related rendering problem. All the non-font elements look correctly anti-aliased. Some of it seems a bit too garbled to just be subpixel modes, I think windscape's suggestion of DPI is more likely.
 
It looks like wide screens are a problem


From: handbook

5.9.2. Adding a Widescreen Flatpanel to the Mix
This section assumes a bit of advanced configuration knowledge. If attempts to use the standard configuration tools above have not resulted in a working configuration, there is information enough in the log files to be of use in getting the setup working. Use of a text editor will be necessary.

and I don't think mine is picking up everything like it should

Code:
[1323007.240] (--) NVIDIA(0): LG Electronics LG ULTRAWIDE (DFP-0): Internal TMDS
[1323007.240] (--) NVIDIA(GPU-0): LG Electronics LG ULTRAWIDE (DFP-0): 330.0 MHz maximum pixel clock
[1323007.240] (--) NVIDIA(0): DFP-1: Internal TMDS
[1323007.240] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[1323007.240] (--) NVIDIA(0): DFP-2: Internal TMDS
[1323007.240] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[1323007.240] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[1323007.240] (**) NVIDIA(0):     device LG Electronics LG ULTRAWIDE (DFP-0) (Using EDID
[1323007.240] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
[1323007.242] (==) NVIDIA(0):
[1323007.242] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[1323007.242] (==) NVIDIA(0):     will be used as the requested mode.
[1323007.242] (==) NVIDIA(0):
[1323007.242] (II) NVIDIA(0): Validated MetaModes:
[1323007.242] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[1323007.242] (II) NVIDIA(0): Virtual screen size determined to be 2560 x 1080
[1323007.266] (--) NVIDIA(0): DPI set to (81, 80); computed from "UseEdidDpi" X c


I tried the @ some point solution, previously

At some point, it will be as easy as adding one of these resolutions as a possible Mode in the Section "Screen" as such:

Code:
Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 24
SubSection "Display"
    Viewport  0 0
    Depth     24
    Modes     "1680x1050"
EndSubSection
EndSection


but I think I need more like the example

Code:
Section "Monitor"
Identifier      "Monitor1"
VendorName      "Bigname"
ModelName       "BestModel"
ModeLine        "1680x1050" 146.2 1680 1784 1960 2240 1050 1053 1059 1089
Option          "DPMS"
EndSection

trouble is I don't see that stuff in my log. Time to 'duck it' (my term for the 'googling' alternative) :)
 
lol wblock@

Actually you can see that in the screenshot :) (xrandr that is).

but

Code:
Screen 0: minimum 8 x 8, current 5120 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected primary (normal left inverted right x axis y axis)
DVI-I-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
  1920x1080  60.00*+
  1680x1050  59.95  
  1600x1200  60.00  
  1440x900  59.89  
  1400x1050  59.98  
  1280x1024  75.02  60.02  
  1280x960  60.00  
  1152x864  75.00  
  1024x768  75.03  70.07  60.00  
  800x600  75.00  72.19  60.32  56.25  
  640x480  75.00  72.81  59.94  
  640x400  70.10  
HDMI-0 connected 1600x900+1920+0 (normal left inverted right x axis y axis) 443mm x 249mm
  1600x900  59.98*+
  1920x1080  59.94  50.00  60.05  60.00  50.04  
  1400x1050  59.98  
  1280x1024  60.02  
  1280x720  59.94  50.00  
  1024x768  75.03  60.00  
  800x600  75.00  60.32  
  720x576  50.00  50.08  
  720x480  59.94  60.05  
  640x480  75.00  59.94  59.93  
DVI-D-0 connected 1600x900+3520+0 (normal left inverted right x axis y axis) 443mm x 249mm
  1600x900  60.00*+
  1280x1024  60.02  
  1152x864  75.00  
  1024x768  75.03  60.00  
  800x600  75.00  60.32  56.25  
  640x480  75.00  59.94

I've just tried setting the DPI to 96.


Code:
[1408010.712] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[1408010.712] (**) NVIDIA(0): Option "UseEdidDpi" "False"
[1408010.712] (**) NVIDIA(0): Option "DPI" "96 x 96"
[1408010.713] (**) NVIDIA(0): Enabling 2D acceleration
[1408011.087] (II) NVIDIA(0): NVIDIA GPU GeForce GT 640 (GK107) at PCI:2:0:0 (GPU-0)
[1408011.087] (--) NVIDIA(0): Memory: 2097152 kBytes
[1408011.087] (--) NVIDIA(0): VideoBIOS: 80.07.55.00.40
[1408011.087] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[1408011.111] (--) NVIDIA(0): Valid display device(s) on GeForce GT 640 at PCI:2:0:0
[1408011.111] (--) NVIDIA(0):  CRT-0
[1408011.111] (--) NVIDIA(0):  LG Electronics LG ULTRAWIDE (DFP-0) (boot, connected)
[1408011.111] (--) NVIDIA(0):  DFP-1
[1408011.111] (--) NVIDIA(0):  DFP-2
[1408011.111] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[1408011.111] (--) NVIDIA(0): LG Electronics LG ULTRAWIDE (DFP-0): Internal TMDS
[1408011.111] (--) NVIDIA(GPU-0): LG Electronics LG ULTRAWIDE (DFP-0): 330.0 MHz maximum pixel clock
[1408011.111] (--) NVIDIA(0): DFP-1: Internal TMDS
[1408011.111] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[1408011.111] (--) NVIDIA(0): DFP-2: Internal TMDS
[1408011.111] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[1408011.111] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[1408011.111] (**) NVIDIA(0):  device LG Electronics LG ULTRAWIDE (DFP-0) (Using EDID
[1408011.112] (**) NVIDIA(0):  frequencies has been enabled on all display devices.)
[1408011.113] (==) NVIDIA(0):
[1408011.113] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[1408011.113] (==) NVIDIA(0):  will be used as the requested mode.
[1408011.113] (==) NVIDIA(0):
[1408011.113] (II) NVIDIA(0): Validated MetaModes:
[1408011.113] (II) NVIDIA(0):  "DFP-0:nvidia-auto-select"
[1408011.113] (II) NVIDIA(0): Virtual screen size determined to be 2560 x 1080
[1408011.137] (**) NVIDIA(0): DPI set to (96, 96); computed from "DPI" X config option

Didn't fix the issue :(
 
oh if it helps:

Monitor

LG 34UM67-P ultrawide 34 21:9

the supported refresh rates of 48-75 Hz

I hope the 'freesync' isn't a problem. From my understanding, it shouldn't be. It should just use a fixed but?

I'm definitely not an expert @ monitors and their settings.

 
The latest xrandr output is different from what is shown in the earlier picture. The earlier one says 2560x1080, the later one says 1920x1080. Not sure what Nvidia means by "DFP". Higher-resolution monitors (over 1920x1200) require dual-link DVI cables.

Since it has not been stated, that monitor's native resolution is 2560x1080.
 
Don't know why they're diff. Hope I didn't grab the wrong info. I saved to file then ssh'd to get. I'll have to try a different cable.

Thank you wblock@
 
Well I rebooted and 'low and behold' it's working @ the lower resolution. Before I was just stopping and starting the X server. Don't know why the windows cure-all worked but not looking it 'in the mouth' right now. Thank You all. I will try and get the other resolution working when I get back... off to Linux Fest!! in Austin, TX ... :)
 
Back
Top