Networkmgr not working on kde5

Leveret

Member

Reaction score: 6
Messages: 44

I used to be able to stop or restart networkmgr from an icon installed on taskbar. Now it doesn't seem to function. My doas.conf file is in /usr/local/etc and contains these lines:

permit nopass keepenv root
permit :wheel
permit nopass keepenv :wheel cmd netcardmgr
permit nopass keepenv :wheel cmd ifconfig
permit nopass keepenv :wheel cmd service
/etc/rc.d/netif restart
Is there anything about kde5 that might interfere with this? I either have to reboot and make sure my DSL modem is turned on or restart from command line with: /etc/rc.d/netif restart.
 

Minbari

Well-Known Member

Reaction score: 169
Messages: 322

The developer removed a line from comments and without that line wifi is not working. So you need to add to doas: permit nopass keepenv :wheel cmd wpa_supplicant
 
OP
OP
L

Leveret

Member

Reaction score: 6
Messages: 44

I copied and pasted the code: permit nopass keepenv :wheel cmd wpa_supplicant. I put it as the last line in doas.conf. After a reboot I still couldn't start the service without using:
/etc/rc.d/netif restart. I'm unfamiliar with the in's and out's of networking. Does the code you suggested only apply to wifi? I am using a Landline connection through a DSL modem.
 

Phishfry

Son of Beastie

Reaction score: 1,177
Messages: 3,409

That is correct. The wpa-supplicant line is not needed for wired ethernet interfaces.
 

Minbari

Well-Known Member

Reaction score: 169
Messages: 322

I'm also using a VDSL modem/AP and without that line in doas (wpa_supplicant) I don't have internet connection and yes that line I suggested it's only for wifi.
 
OP
OP
L

Leveret

Member

Reaction score: 6
Messages: 44

I did a "pkg install python3" and everything seems to be working correctly. I had taken a look at a page on the GhostBSD website and thought maybe it was needed. Usually I would turn off my modem and reboot but networkmgr wouldn't connect after rebooting. After installing python3 it seems to automatically connect.
 
OP
OP
L

Leveret

Member

Reaction score: 6
Messages: 44

My optimism was short lived. The problems I'm having with networkmgr still persists. Does anyone have an idea of how to fix this?
 
OP
OP
L

Leveret

Member

Reaction score: 6
Messages: 44

Does anyone currently have networkmgr functioning correctly? I tried installing from packages to no avail. Sometimes, if I turn off my DSL modem, I am unable to reconnect to the Internet when it is turned back on. Is there a way to have automatic detection? This is all I really need.
 

Phishfry

Son of Beastie

Reaction score: 1,177
Messages: 3,409

Where I live the DSL providers use PPPoE. This requires a connection daemon.
Straight up PPP is normally used to connect using a user/password.
net/mpd5 provides many advantages over pure PPP solution.

So if you have an PPP connection please consider mpd5. It handles re-connections gracefully.
networkmgr is best used for Wifi connections. It has no PPPoE capability that I know of.
 
OP
OP
L

Leveret

Member

Reaction score: 6
Messages: 44

I can always connect to the internet if my modem is on when I boot the system. What I was hoping for was something that would allow me to automatically reconnect if I had turned the modem off and then decided to turn it back on. I'm new to networking and PPPoE. I hoped someone could tell me if they are using networkmgr with a DSL modem or if it is unworkable on FreeBSD. Maybe someone can point me to a tutorial for beginners on PPP or mpd5.
 

Phishfry

Son of Beastie

Reaction score: 1,177
Messages: 3,409

With you connecting sometimes the chance that you are connecting via a DSL modem directly is slim.
You would have to configure PPP to get any connection.
I am going to take a wild guess here and say you probably have a DSL modem with built in Router.
The router end handles authentication instead of a software PPP client.
Does that sound correct?
What mfg/model is your modem exactly?
 

Phishfry

Son of Beastie

Reaction score: 1,177
Messages: 3,409

What I was hoping for was something that would allow me to automatically reconnect if I had turned the modem off and then decided to turn it back on.
For this use case try and restart the network stack.
service netif restart

Your IP could change when you turn modem off and then on. So you need to restart the FreeBSD network.
There may be some automatic way to do this, I have a feeling if you waited a few minutes the system would do this itself.
dhclient should detect the new IP lease and add it.
I would be monitoring ipconfig. See if it reporting the interface 'UP'.
 
OP
OP
L

Leveret

Member

Reaction score: 6
Messages: 44

It is westell and it does have a router. I did try SYNCDHCP in my rc.conf file but it didn't seem to be what I needed.
 

Phishfry

Son of Beastie

Reaction score: 1,177
Messages: 3,409

If the router is setup correctly then a power cycle of the modem/router will be picked up by FreeBSD.

Look at ifconfig. It is your friend here. See if the connection is active. Make sure the interface is up.

There are no network managers needed to connect to FreeBSD wired ethernet.
Everything is called up automatically from rc.conf and the status comes from ifconfig.
 
OP
OP
L

Leveret

Member

Reaction score: 6
Messages: 44

I'm using the settings created for my system during install and I am able to connect to the internet if my modem is on at boot. The problem is when I turn it off, while still being logged into my system, and then decide to turn it on to reconnect to the internet, or if I only turn it on after I log in. In these cases it will only sometimes connect. I can alwas connect by using: /etc/rc.d/netif stop and then /etc/rc.d/netif start as root. I've made this a bit simpler by writing a small gui in wxPython to issue theses commands. After I enter my root password, a small window appears and I simply click a button to connect or disconnect. I just wish the modem would always connect on its own, which it might not if I am already logged in and decide to only then turn it on.
 
Top