Mouse not working at all in FreeBSD 11

BoggledByBSD

Member


Messages: 23

During installation, my mouse is detected fine. However, after the first boot, the mouse cursor shows up in the console, but won't move. I get the following error at the end of the boot sequence:
Code:
Starting default mousedmoused" unable to open /dev/psm0: No such file or directory

It works fine on 10.3, any ideas?
 

wblock@

Beastie Himself
Developer

Reaction score: 3,779
Messages: 13,851

If this is a USB mouse, remove moused_enable="YES" from /etc/rc.conf.
 
OP
BoggledByBSD

BoggledByBSD

Member


Messages: 23

No luck with that. During setup I am asked to enable the mouse for console, and if I leave that unchecked, it omits the line you described. Doing this, I have no mouse in the console, and it appears but won't move in my desktop environment.

When booting into the install environment, I see this right before the mouse cursor pops up and is usable:
Code:
Starting ums0 moused.
This line also appears when booting into 10.3 after installation.
Is there any way to clone what happens in the install environment or 10.3, like having moused point to /dev/ums0 instead of /dev/psm0?

EDIT: The only idea I could come up with myself was to create a symbolic link pointing from /dev/psm0 to /dev/ums0 or /dev/sysmouse, but I have little experience with how symlinks work, and they don't seem to persist after a reboot.

I'm not seeing any other posts from people having this problem, so I'll just roll back to 10.3 for now.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,779
Messages: 13,851

You don't actually say it, but /dev/ums0 means you have a USB mouse. For USB mice, moused(8) is started automatically. Why is it not being started on that system? Maybe UEFI/BIOS device emulation. I have a system like that here, which I have not investigated.
 
OP
BoggledByBSD

BoggledByBSD

Member


Messages: 23

That is correct, it is a USB mouse. I apologize for not explicitly saying it, but I thought your assumption was solid and there was no need.

After rolling back to 10.3, what you say is of course correct, I do not need that line in my rc.conf for the mouse to work. However, in 11, the USB mouse will not move under any circumstance. I can get the touchpad to work if I enable it in the BIOS, and I had suspected the same as you - that possibly a combination of my BIOS configuration and how I install the boot partition are causing the problem.

On this particular system, FreeBSD 11 seems much more picky about how I install the boot partition. I have to use ZFS with MBR, or the disk is not recognized as bootable.

I have my BIOS on this system configured for compatibility mode(CSM), and I've also noticed there is no specific UEFI image for FreeBSD 11. Could something like this be the problem?
 

Atsuri

Active Member

Reaction score: 25
Messages: 137

That is correct, it is a USB mouse. I apologize for not explicitly saying it, but I thought your assumption was solid and there was no need.

After rolling back to 10.3, what you say is of course correct, I do not need that line in my rc.conf for the mouse to work. However, in 11, the USB mouse will not move under any circumstance. I can get the touchpad to work if I enable it in the BIOS, and I had suspected the same as you - that possibly a combination of my BIOS configuration and how I install the boot partition are causing the problem.

On this particular system, FreeBSD 11 seems much more picky about how I install the boot partition. I have to use ZFS with MBR, or the disk is not recognized as bootable.

I have my BIOS on this system configured for compatibility mode(CSM), and I've also noticed there is no specific UEFI image for FreeBSD 11. Could something like this be the problem?

The 11.0-RELEASE images are hybrid .isos or .imgs. They are compatible with both UEFI-mode and legacy BIOS-mode. I actually had similar problems as you with the CSM mode, though what helped me was creating both an efi and freebsd-boot partitions without assigning mount points to them during the install process via bsdinstall. Then I could boot via UEFI-mode no problem. Maybe you could try this.

Otherwise, the line:
Code:
Starting default mousedmoused" unable to open /dev/psm0: No such file or directory
might not mean anything as I often had this error message on my 10.3-RELEASE installation and the moused daemon would recognize both the trackpad and USB mouse without a hitch anyhow.
 
OP
BoggledByBSD

BoggledByBSD

Member


Messages: 23

The 11.0-RELEASE images are hybrid .isos or .imgs. They are compatible with both UEFI-mode and legacy BIOS-mode. I actually had similar problems as you with the CSM mode, though what helped me was creating both an efi and freebsd-boot partitions without assigning mount points to them during the install process via bsdinstall. Then I could boot via UEFI-mode no problem. Maybe you could try this.

Otherwise, the line:
Code:
Starting default mousedmoused" unable to open /dev/psm0: No such file or directory
might not mean anything as I often had this error message on my 10.3-RELEASE installation and the moused daemon would recognize both the trackpad and USB mouse without a hitch anyhow.

So during the installer, you would create a partition scheme manually like this:
ada0 - GPT
ada0p1 - efi
ada0p2 - freebsd-boot
ada0p3 - freebsd-swap
ada0p4 - freebsd-ufs

Am I understanding this correctly?
 

Atsuri

Active Member

Reaction score: 25
Messages: 137

Yes, though I just now did a re-install of FreeBSD 11.0-RELEASE without the freebsd-boot partition on the same computer and booting works just fine. I guess I messed something up earlier, my apologies! Therefore, the partitioning scheme should look as follows:
ada0 - GPT
ada0p1 - efi
ada0p2 - freebsd-swap
ada0p3 - freebsd-ufs mountpoint /
(ada0p4 - freebsd-ufs with optional /home)
 
Top