Mouse in KDE 3.5

Lego

Well-Known Member

Reaction score: 1
Messages: 404

ok so, I got frustrated and downloaded disc 2 and 3. did a complete install again. installed KDE. Still don't have my net working but i'll figure that out; KDE tells me that my sound isn't working either again, not the priority. But first I would like to get my mouse working in KDE.

When I did the sysinstall again. I configured the mouse, and it works! ....in the console mode (terminal i guess you call it). but when i boot up kde my mouse doesn't work anymore.

Its a Logitec wireless mouse keyboard combo (1 usb plug 1 green serial for the mouse serial port. I don't use the keyboard but I do use the mouse. why does it only work in the terminal??

its set for Bus mouse, serial, pnp (the top one) for type and its set on com1 for the port. and like i said it works in the terminal were as all the other setting don't allow it to work in the terminal. or is there special setting i need to setup for kde?
 

Djn

Well-Known Member

Reaction score: 67
Messages: 392

I take it you mean X in general when you say KDE.
Anyway - if you look at /etc/X11/xorg.conf, do you have a section like this?
Code:
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection


And if you do, what does ls -l /dev/sysmouse say?

Also - do you use the USB connector for the mouse?
If you do, it might be best to just remove all mentions of moused in /etc/rc.conf , since it should be autodetected at boot anyway.

Oh, and try disconnecting and reconnecting the mouse while in X - sometimes that fixes things.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Djn said:
I take it you mean X in general when you say KDE.

No I mean in KDE; like in the desktop with the login screen and the clock in the bottom right... like windows. system and stuff in the top right. (KDM from the console then it loads). maybe im using the wrong term but when i type startx is starts Xorg, when i type KDM it start KDE 3.5. im talking KDE. either way.

yes, its a usb mouse... it is a combo (mouse/keyboard) with both... a serial mouse plug and a usb plug...

I have no files in the X11 folder :S. Its empty. weird. but Xorg starts with startx.

ls -l /dev/sysmouse returns this:
crw------ 1 root wheel 0, 13 Nov 28 13:17 /dev/sysmouse
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

I would also like to add that when xorg starts i have no mouse aswell. and when i use Ctrl + Alt + Backspace to leave xorg or KDE i get a flashing thin line across the top and thats it! it crashes..
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

i've been to that page. its for setting up xorg. i don't need that i want to fix my mouse and use KDE.
 

Andrius

Member

Reaction score: 6
Messages: 38

Lego said:
when i type startx is starts Xorg

Let me guess, the mouse doesn't work there, does it?

If you want your mouse to work in kde, then get it to work in Xorg, at least try doing the stuff handbook says you to do.
Something like Xorg -configure can help.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

I see, so setting up the mouse in xorg will fix it in KDE?

my mouse has been set in the sysinstall. and works. it just doesn't work when i boot xorg or kde.
 

caesius

Well-Known Member

Reaction score: 19
Messages: 280

Lego said:
I see, so setting up the mouse in xorg will fix it in KDE?

X handles the mouse/keyboard and things like that. KDE is "on top" of this handles/draws the stuff you look at and use (kwin, kicker etc)

That's being very loose with definitions but you get the idea...
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Andrius said:
Well it should, I see no reason it would not work if it works in Xorg.

It doesn't it works when I boot the computer and am in the terminal before i boot xorg or kde, it stops working when i boot to xorg or kde.
 

Andrius

Member

Reaction score: 6
Messages: 38

I had similar problem (mouse worked in console, but not in Xorg) with bad xorg.conf. Command "X -configure" gave me a usable configuration file that fixes mouse problems.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Andrius said:
I had similar problem (mouse worked in console, but not in Xorg) with bad xorg.conf. Command "X -configure" gave me a usable configuration file that fixes mouse problems.

Ok typed that and it detected a mouse and stuff. then put startx....

now my computer has been sitting with a small white line across the top of the monitor and the rest all black , but my hdd light is going mad?? the same like that i get when i try and control alt backspace to exit xorg or kde...

ADDED:

I ran it like the X11 config page says:

Xorg -config xorg.config.new
and x just crashes.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

ok KDE still boots but it takes a darn long time now......still no mouse.

ADDED:

Ok startX and kdm both boot normal now.. speed wise... but i still have no mouse, i went back into the sysinstall. and tried setting it again. whats weird is no matter what combination of setting I use, it doesn't work from the sysinstall, but when im in the console it works. but when i boot to x or kde it stops again? what the heck am I doing wrong. man, no mouse, no net, no sound.. LOL wow Im on a roll :p

Forgot No USB! LOL
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

SUCCESS!! MANY THANKS! TO EVERONE! sorry about the caps :D Im just happy, 1 down a few more to go!
 

cajunman4life

Active Member

Reaction score: 20
Messages: 119

Kindly tell us the method you used for fixing your problem, so that others in the future will know
 

Djn

Well-Known Member

Reaction score: 67
Messages: 392

Quoting the PMs behind this:
Djn said:
Lego said:
Hey, hope you don't mind the PM, ok so i removed all moused info from the rc.conf, and when i booted the /etc/X11/xorg.conf there was nothing in it, but i have ran the Xorg -Configure, and x and kde boot normal now. rather, again, but i still seem to have no mouse? I have also gone back into the sysinstall and set the mouse to work.

Right, let's see ...

First of all, just let me describe in very short how this all ties together:

In FreeBSD, all mice connected to the system are picked up by moused (a FreeBSD-specific little server) that adds them all together, and creates a device (/dev/sysmouse) that will look the same no matter what mice are connected. Moused is also what gives you a pointer in the console.

KDE runs on top of X, which is basically the graphics/mouse/keyboard drivers and a thin layer on top.

Since moused apparently works (you've got a pointer in the console), the missing link is to connect X to moused.


When you run X -configure, it will create a new config file, but it won't copy it to /etc/X11/xorg.conf .(The idea is that it that you should be allowed to check it before you possibly overwrite the old file.)

To install it, do "cp xorg.conf.new /etc/X11/xorg.conf" after you've run "X -configure" , then try running "X".

If that works, great]Section "InputDevice"[/i] with Driver "mouse": You want to rewrite that so it looks exactly like this:

Code:
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection


To save and exit, press Esc, Enter, Enter. To quit without exiting, press Esc, Enter and select No Save, then press Enter.
(Or, in general: Esc for the menu, arrows to move, enter to select. )

With that done, try starting X again.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Thanks again Djn! lol :D and yes that is exactly how I got it fixed :)
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Thanks again Djn! lol Also, This part was not required for me:
If that works, great; if not you probably need to add moused to the config file.
run "ee /etc/X11/xorg.conf" and you'll get a text editor.
 
Top