Mouse "Click" problem with GNOME3

Hello, I am a newbie on this FreeBSD forum and I thank you for welcoming me and for any information and or answer the community could give me back.

I want to install Free BSD "Gnome Desktop" on 2 computers :

  • Workstation (Homemade) :
Proc:Intel Core 2 "Quad" / Ram:8 Gb / Disk : 250Gb / Graphic Card : NVidia GT220

  • Laptop (Dell Vostro 1700) :
Proc:Intel Core 2 "Duo" / Ram:4 Gb / Disk : 200Gb / Graphic Card : NVidia 8600M GT


I have processed step by step to check whether the methodo I am applying is ok or not.


- STEP#1 : The X Window System (Chapter 5)
- Xorg Install as specified in :
https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-install.html

- Xorg Configuration as specified in :
https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-config.html


- STEP#2 : Install NVidia Driver
- Setting the Free BSD Nvidia Driver by compiling the correct driver (e.g. "/usr/port/nvidia-driver-340" for "NV GT220" and "/usr/port/nvidia-driver-304" for "NV 8600M GT") as required in :
https://docs.freebsd.org/doc/7.3-RELEASE/usr/share/doc/en/articles/compiz-fusion/nvidia-setup.html


- STEP#3 : Launch "X Window" alone
With the startx command
- It is OK! for BOTH Workstation (NV GT220) and Laptop (NV 8600M GT)


- STEP#4 : Install XDM (+) Launch "XWindow"
As it is specified in : https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-xdm.html
- It is OK! for BOTH Workstation (NV GT220) and Laptop (NV 8600M GT)


STEP#5 : Install GDM (+) GNOME
As it is specified in : https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11-wm.html
- It is OK! for the Workstation (NV GT220)

but

- It is NOT OK! for the Laptop (NV 8600M GT) e.g. :
In that case, I can move the mouse pointer but I cannot CLIC (neither with "Left" and "Right" buttons) to select menu options even in the GDM loggin window and in the GNOME desktop. The mouse CLICK does'nt work neither with the "Touchpad" nor with an "USB Mouse".


NOTA
(i) To be sure, I made the tests for "FreeBSD 10" and the comming "Free BSD 11" but I got the same bad result for the laptop

(ii) I made the test with the "KDE" desktop and then, it is OK! for BOTH Workstation and Laptop!

I guess it is some kind of "Touchpad" configuration problem with GNOME, or maybe it's an error from me.

If you have any idea, thank you for answering me .


PS Here is my /usr/local/etc/X11/xorg.conf file generated by the nvidia-xconfig command.
 

Attachments

  • xorg.conf
    1.3 KB · Views: 283
(ii) I made the test with the "KDE" desktop and then, it is OK! for BOTH Workstation and Laptop!
That restrict your problem to gnome related settings, without doubts, but I don't use gnome and am unable to provide further advices.

Adding a new user account, for test, could help to identify if gnome is problematic by default or if there is a setting you misplaced by error.

As as side note, I also have a Nvidia 8600M GS, and the proper driver is 340.96, your xorg.conf look fine.
 
Back
Top