Just installed FreeBSD 10.3 with Mate desktop. All went well, however when plugin my external usb WD HD,500G
It gets this error can't mount
mount_msdosf:/dev/msdosfs/My%20data disk too big try -o large option invalid argument
Don't know where to start? Tried handbook and also google all different answers,
Very confusing. Can you help? Thanks
Just entered
mount_msdosfs -o large /dev/da0s1 /mnt
mount_msdosfs: /dev/da0s1: Device busy
Then tried
mount_msdosfs -o large /dev/da0  /mnt
mount_msdosfs: /dev/da0: Operation not permitted
Maybe your USB storage is not showing up as da0 as mine was. What I would do is Hot-Plug in your USB device. The text on screen will tell you what the device is recognised as and will give the device node. You will need to append "s1" on the end as this is "slice1" or "partition 1" in msdos terms. Is there more than one partition on the drive?

Are you sure it is FAT32? Newer Windows will not format a FAT32 partition over 128GB.
  • Thanks
Reactions: fvs
OK Phishfry, Tried another stick 16G and it showed up, It probably was the size of the WD passport, I'll have to format it for
Freebsd. Not sure how? Great job.
Thanks once more.
All went well, I still need a few tweaks to have a perfect working desktop.
Thanks for all the help.