Solved Missing Modifier Keys with VNC and bhyve

I'm running FreeBSD 11.0-RELEASE using bhyve for Linux VMs. They run great, but I'm missing some of the right control keys (e.g. right shift and right control) when I connect with VNC.

Here's the command I'm using to start the VM:

bhyve -A -H -P -s 0:0,hostbridge -s 31:0,lpc -s 2:0,virtio-net,tap0 \
-s 3:0,virtio-blk,/dev/zvol/zroot/crashplan -c 2 -m 2048M \
-s 29,fbuf,tcp=,w=1280,h=1024 \
-s 30,xhci,tablet \
-l bootrom,/usr/local/share/uefi-firmware/BHYVE_UEFI.fd crashplan

From the Linux VM I have run both of these commands, and neither show the keycodes even getting to the X server:


I have also verified my VNC client works with these keys on other machines, and even tried using a FreeBSD VNC client from the host machine. I've also tested three different Linux distributions with the same results.

Does anyone have similar experiences, or any ideas on things I could try?

Thanks for any assistance.
I updated to 11.1-RELEASE and all the modifier keys now work with the bhyve VNC server. Many thanks to the FreeBSD devs!