Missing lib32 on freebsd-update to 10.1-RELEASE

dal36

New Member

Reaction score: 6
Messages: 8

I've just updated one of my machines (amd64) from 10.0-RELEASE-p12 to 10.1-RELEASE using freebsd-update and found that the usual contents of /usr/lib32 were missing afterwards.

To replicate, I've attempted the following process on a fresh install of FreeBSD 10.0-RELEASE (amd64), after having selected all optional items (including lib32) in the installer:
Code:
# freebsd-update fetch install
# reboot
# freebsd-update -r 10.1-RELEASE upgrade
# freebsd-update install
# reboot
# freebsd-update install
# reboot
# freebsd-update install
# reboot
I.e. freebsd-update to the latest release on the security branch, followed by the upgrade process itself.

After the first invocation of freebsd-update install, /usr/lib32 contains a large number of library files, but after the second invocation, it only contains the following three folders (all empty):
Code:
# ls /usr/lib32
dtrace i18n private
Has anyone else experienced similar behaviour? I've found a couple of somewhat similar issues on the mailing list and the forums, but nothing conclusively the same. It would be useful to know if this is a bug in the installer, a change in the base system (i.e. not an issue at all) or simply due to following the upgrade process incorrectly. Thanks in advance.
 
OP
OP
D

dal36

New Member

Reaction score: 6
Messages: 8

One further point: freebsd-update -r 10.1-RELEASE listed world/lib32 amongst the installed components when following this process; the 'not installed' part of the listed components was empty.
 
  • Thanks
Reactions: VVD
OP
OP
D

dal36

New Member

Reaction score: 6
Messages: 8

Thanks for the suggestion. I've rerun the process described above and got the same results as before. freebsd-update -r 10.1-RELEASE upgrade was called just after 00:15 UTC on 17 November.
 
  • Thanks
Reactions: VVD
OP
OP
D

dal36

New Member

Reaction score: 6
Messages: 8

Thanks for letting me know about that. I haven't had any segfaults yet, but it seems possible that there's a common cause. I will follow along and chip in if I get any segfaults or other relevant issues.
 
  • Thanks
Reactions: VVD

VVD

New Member

Reaction score: 1
Messages: 9

I've just updated one of my machines (amd64) from 10.0-RELEASE-p12 to 10.1-RELEASE using freebsd-update and found that the usual contents of /usr/lib32 were missing afterwards.
I have the same issue. Tried just now.
 
Top