misc/mc problem

I see what speak about Ctrl+O on mc... this brokened ...

1. solution.
Simple ... editing /etc/termcap:
added 3014 string
Code:
3010 # This is the only entry which you should have to customize, since "xterm"
3011 # is widely used for a variety of incompatible terminal emulations including
3012 # color_xterm and rxvt.
3013 xterm|X11 terminal emulator:\
3014 <------>:te=\E[?1049l:ti=\E[?1049h:\
3015 <------>:tc=xterm-new:
3016 #<----->:tc=xterm-r6:
"<------>" this is 'tab" (aka '\t')
and exec command:
# cap_mkdb -f /usr/share/misc/termcap /etc/termcap

снимет как рукой. :)
This is hack :( not good but is worked.

2. solution.

change value $TERM (or $term) from xterm to xterm-clear
tcsh:
setenv TERM xterm-clear ; setenv term xterm-clear

sh, bash, zsh:
export TERM=xterm-clear ; export term=xterm-clear

but will not work keys combinations type: Shift+F5,F6... :(
 
I have solved this problem by switching to bash shell

chsh -s /usr/local/bin/bash

p.s. if you don't have bash then run this # sudo pkg install bash

And then close console, login again and you all set.
 
I have solved this problem by switching to bash shell
chsh -s /usr/local/bin/bash
This is not a real solutions: mc() doesn't depend on bash() (which is not a part of the base system):
Code:
% pkg info -d mc
mc-4.8.22_1:
    libXext-1.3.4,1
    libX11-1.6.8,1
    diffutils-3.7
    libssh2-1.8.2,3
    python27-2.7.16_1
    perl5-5.30.0
    libslang2-2.3.2_1
    glib-2.56.3_6,1
    gettext-runtime-0.20.1
If it really does/should, a bug report must be filed.
 
This is a very old issue and it still happens and still, no one filed a report? I'm surprised.
Maybe this is not a real solution but it works.
 
Interesting - I have had zero issues with misc/mc except. that when used by root it butchers root's shell history. That is using the package - if I build from ports and take out an option related to shell, then it's fine. Normally I use zsh for my user and leave root's alone. An alternate method if I don't want to build from ports is have root use sysutils/lfm although I find it to be a little cludgy compared to misc/mc.
 
D

Deleted member 30996

Guest
I remember enabling the subshell option when I was building it from ports. It works as root but I get the same error as OP when invoking it from my user account.
 
Hi.
What about to do link to mc?
mc -> mc_csh

Code:
#!/bin/sh
/bin/csh mc

How to fix this problem?

What is mc -u?
It works for me from /bin/sh...
 
Dear riselost,
in misc/mc it is possible to start a shell by typing CTRL+O. There has an issue with csh or so. From that shell misc/mc refused to start or even crashed because of the subshell. mc -u starts the program with the subshell option disabled. This allowed using misc/mc slightly limited in the problematic shell. I am not sure if the problem still exists.
 
Top