• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

milter-greylist segfaults after upgrading curl and restarting jail

kjpetrie

Member


Messages: 66

#1
Yesterday I upgraded ftp/curl in my 10.3-RELEASE-p20 mail jail to version 7.56.0. Today I noticed there was no security or daily run mail from the mail jail this morning, so I restarted the jail. Since then I have been unable to start mail/milter-greylist.

Code:
root@mailijail:~ # service milter-greylist restart
miltergreylist not running?
Starting miltergreylist.
Segmentation fault (core dumped)
/usr/local/etc/rc.d/milter-greylist: WARNING: failed to start miltergreylist
I have tried rebooting the whole server and forcing a re-install of mail/milter-greylist but this has made no difference.

What should I do now?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,507
Messages: 25,688

#2
Rebuild mail/milter-greylist. The upgrade of ftp/curl probably also updated its libraries, and milter uses those. So now your dependencies are out of sync.
 

kjpetrie

Member


Messages: 66

#3
Thank you. I have now rebuilt it 3 times, twice without curl support and once with (alternating). With curl support it crashes, but without curl it runs.

So, it looks like it depended on whatever was changed in the security upgrade! I'm in touch with the maintainer, so I'll relay that news to him.

Not solved yet, but hopefully on the way.