MATE Mate not logging in

dhenzler

Member

Thanks: 2
Messages: 57

#1
I give up... been through several tutorials, and I have followed them to a letter.

installed xf86-video-nv which supports my card
installed hal from ports
installed slim from ports
dbus was installed by one of the above

dbus_enable="YES"
hald_enable="YES"
slim_enable="YES"

installed mate from ports

.xinitrc mate-session in both user and root

system stops at GUI login screen and nothing happens when I type.

<CTRL> <ALT> + <F1> exits the GUI and will allow terminal login

xinit mate-session fails to do anything

I am stuck here... and by all the stuff I've read it should work

I tried editing /etc/ttys and wound up having to re load FreeBSD because I couldn't get back in to edit it again. The last edit was to replace xdm with slim in the virtual tty#8 (I think)

Help would be appreciated.

Dave - dhenzler@sonic.net
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#2
Generally it is advisable to disable login managers for testing in such cases.
Then it is much easier to find problems causes.
Log in from console. Then check if startx works fine. When this works, check whether mate-session (or whatever command starts it) works. When all this works fine, enable the login manager as last step.
 
OP
OP
dhenzler

dhenzler

Member

Thanks: 2
Messages: 57

#3
startx doesn't work... is it a requirement, or is .xinitrc sufficient to start mate?
however X must be working as I have a GUI login screen.
Entries from keyboard are ignored.
I have .xinitrc which has one line... exec mate-session.
The issue here isn't that mate isn't running... the question is why the login screen isn't taking keyboard input.
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#4
Yes X windows is a prerequisite. Many stumble about this problem.
Installing only the desktop manager only installs an (incomplete) part of X window system, which might explain your issues with the login manager.

If there still are issues after pkg install xorg, please don't hesitate to ask here.
 
OP
OP
dhenzler

dhenzler

Member

Thanks: 2
Messages: 57

#5
Ok deleted slim and loaded xinit from ports. Created a NEW .xinitrc file with one line... exec mate-session. Now Mate starts up, but no mouse... and maybe no keyboard. I use a logitech N231 USB mouse, and a logitech wireless keyboard that uses a USB dongle. Have seen flashes of the driver stuff when fooling with ghostBSD. (Wonder why if it's so easy to detect... why don't they just auto detect in the real OS?????)

Anyway... looks like I'm nearly there.. now just need keyboard & mouse.

D
 
OP
OP
dhenzler

dhenzler

Member

Thanks: 2
Messages: 57

#7
I have done all that you have... Unfortunately my mouse isn't found. & perhaps my keyboard... when I got to the slim login screen... no mouse... no keyboard. I had to ctrl alt f1 to exit and then I can startx and get mate-session running. However no mouse no keyboard
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#8
Hmm the fact that you can switch to console using the keyboard indicates that the keyboard is working.

I suspect that it could be a problem with the InputDevice section of the xorg configuration file(s).
These are usually in directory/etc/X11/.... In case there are no such files on your computer, do not wonder, this is today's standard (autoconfiguration). But for some reason this autoconfiguration stuff does not always work.

My problem is that I am not good in helping in an easy way, I sincerely apologize.
I do that too complicated, because I configure that stuff manually instead of using autodetect. (Which is not recommended and frowned up by most users here)

It's night in Europe now, and the forum gurus (SirDice, tobik@ and a few others, too many to name now) will come back in about 8 hours.
These know easier (and probably better) ways to solve such issues than I could.
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#9
The mouse reports 16 buttons, this looks strange, and the other mouse messages also look unusual.
I am looking what this could mean, will post in a few minutes when I (hopefully) got some idea what could be the problem.
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#10
Could you please look into the file /etc/rc.conf and make sure there is no entry like moused_enable="YES" or similar?
As it is an USB mouse, the FreeBSD gurus recommend to not have a "moused_enable" line in /etc/rc.conf.

Edit: The docs say that USB mice are being autodetected, and the messages suggest that there might be an entry that either says logitech or mousesystems, which is intended only for (RS-232) serial and PS/2 mice.
Edit 2: If I understand the docs correctly, for USB mice there is no "mouse_enable" entry necessary, as these get enabled automatically. Even very experienced users like vermaden got caught by that...
 
OP
OP
dhenzler

dhenzler

Member

Thanks: 2
Messages: 57

#11
the 16 button thing is something else... who knows...
first photo
ugen2.2<Logitech USB Optical Mouse> at usbus2
ugen5.2<Logitech USB Receiver> at usbus5
ukbd0 on uhub2
ukbd0 <Logitech USB Receiver, class 0/0, rev 2.00/12/03, addr 2> on usbus5
kbd2 at ukbd0
maybe I should delete moused (seems that it may be crashing the USB mouse.???
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#12
If I understand correctly, moused gets autostarted if USB mice are there.
Could you maybe post your /etc/rc.conf file so we can check that out?

Edit: The 16-button thing seems indeed to be your high-tech mouse :) (it says to your computer 16 buttons, because of all those up-down switches, which are each two or three buttons internally, technically spoken)

Edit 2: Do not delete moused, it is required. There seems just some problem regarding its correct initialization.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,415
Messages: 27,715

#14
You seem to have filesystem errors judging by the "Filesystem not clean - run fsck" message.
 

pensador_13

Active Member

Thanks: 43
Messages: 182

#15
Also it seems that x11/xauth is missing, which is a important Xorg component.
Please show the outputs of dmesg, pkg info, /etc/rc.conf, /var/log/Xorg.0.log and /var/log/Xorg.0.log.old, so that we can help you more.
If you don't mind, it would be better that you post the outputs with the following structure:

dmesg
Code:
Insert the output here...
pkg info
Code:
Insert the output here...
/etc/rc.conf
Code:
Insert the output here...
/var/log/Xorg.0.log
Code:
Insert the output here...
/var/log/Xorg.0.log.old
Code:
Insert the output here...
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#16
Things have changed much since then...
Slowness could be caused by many things including suboptimal driver.
Don't worry, community here is helpful, we'll get that sorted out together :beer:
 

MarcoB

Well-Known Member

Thanks: 92
Messages: 334

#17
Best thing to do I think is to try first with plain Xorg and TWM as a window manager. Then see if that works, and if it is, then add more stuff to rc.conf like DBUS etc. and start Mate. If it doesn't work the right way with plain X and TWM, check the X log files what the problem is.

Looks like there are more issues than one. I'd start with the USB things. Afaik Xorg handles USB keyboards and mice. The moused in rc.conf is only for PS/2 connections.

Also don't start X as root, it should be started as user.
 
OP
OP
dhenzler

dhenzler

Member

Thanks: 2
Messages: 57

#18
Thanks for the help. I don't want to go back to Zero... thank you. Seems the problem is related to the USB Mouse & Keyboard. Drivers are NOT loaded for Xorg. The Mouse works in Terminal mode... which I found to be a bit strange. So that tells me that it's a driver issue. The Mate-Session loads which says that Mate is not failing. Don't believe Mate has ANYTHING to do with Mouse do you?

I just find it difficult to swallow that Live DVD's self configure to work perfectly... then installation drives you to drink trying to duplicate what they did automatically. Seems kinda twisted to me. Even Linux Mint 18.2 Live CD worked fine with ATI video driver on a laptop. But actual installation had issues. I just gave the laptop away and got another one with a different video card. End of problem

by the way what is Afaik?

I think I can get the data that was requested using ssh from another computer. Midnight commander does an SSH link and with two windows I can put the info into a file and upload it. Perhaps tomorrow. Carpets got cleaned today, and are still damp 8 hours later. So am tip toeing around and trying not to make a mess of the freshly cleaned look.

By the way the fsck error... can't make fsck run, and it may be erroneous. I'm using a ZFS system. fsck is for the UFS system isn't it ?

Later
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#19
Take care of good ventilation... most important that the carpets don't get moldy/stinky now. Maybe a summer ventilator helps speeding drying up...

The computer doesn't run away :)

(yes, fsck is for ufs. zfs has other tools)
 
OP
OP
dhenzler

dhenzler

Member

Thanks: 2
Messages: 57

#20
USB driver info.... https://www.freebsd.org/cgi/man.cgi?query=ums&sektion=4

To load the driver as a module at boot time, place the
following line in loader.conf(5):

ums_load="YES"

EXAMPLES
Use the first USB mouse on the system as your console mouse:

moused -p /dev/ums0 -t auto

To be able to use the USB mouse under X, change the "Pointer" section in
xorg.conf to the following:

Device /dev/ums0
Protocol Auto

If you want to be able to use the mouse in both virtual consoles as well
as in X change it to:

Device /dev/sysmouse
Protocol Auto
////////////////////////////////////////////////////////////////////
https://forums.freebsd.org/threads/64262/

(very similar to my setup)
Fresh install FreeBSD 11.1 (Guided ZFS Stripe MBR Bios),
usb wired mouse is not working.

There isn't any /dev/ums* device.

USB Dump:
Code:
usbconfig -u 4 -a 2 dump_info
ugen4.2: <vendor 0x275d USB OPTICAL MOUSE> at usbus4, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON (100mA)

usbconfig -u 4 -a 2 dump_curr_config_desc
ugen4.2: <vendor 0x275d USB OPTICAL MOUSE> at usbus4, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON (100mA)

& more see URL above to get all
 
OP
OP
dhenzler

dhenzler

Member

Thanks: 2
Messages: 57

#21
By the way the fsck error... can't make fsck run, and it may be erroneous. I'm using a ZFS system. fsck is for the UFS system isn't it ?

Later
BTW
"How do you use fsck with a ZFS filesystem? The answer is that you do not. ZFS filesystems are always clean"​
 
Last edited:

macondo

Active Member

Thanks: 58
Messages: 137

#25
You seem to have filesystem errors judging by the "Filesystem not clean - run fsck" message.
A couple of months ago I had a similar problem with my wm, I decided "not to fish and cut bait", got a 120gb SSD, reinstalled and problem solved. The old hd had seen more action (metadata) than Fallujah.

Celeron desktop with 4 megs ram.
 
Top