Solved Mate And Slim Malfunctioning After Upgrade

I upgraded one of my machines from FreeBSD 10.3 to 11.0. Before I started, I used Mate as the desktop and Slim as the login manager.

After upgrading, Slim won't execute because, apparently:

is missing. However, I can start Mate with:

xinit mate-session

but the background I used before I started the upgrade is now missing.

How can I fix or work around this or would I be better off by starting again from scratch and making a clean installation of FreeBSD 11.0?

Any advice or suggestions would be welcome. Thank you.

Update after original posting:

I tried:

pkg remove jpeg-turbo
pkg install jpeg
pkg install mate-desktop mate
pkg slim

I now have the previous background back. However, Slim still doesn't work. There seems to be a conflict with a


file, though I didn't note which one.

Also, I can't shut down my computer from my personal account when running Mate, though I can when logged in as root.

I'm not sure what to do next. Thanks.

graphics/jpeg-turbo is faster then jpeg. Maybe you should install graphics/jpeg-turbo and force install of whomever depends on jpeg? I'm not sure how to do it with pkg, I used to do so with old port system (the old pkg).

Thanks for your reply.

I'm not sure what's going on, but the machine showed some strange behaviour earlier in the day. I was successful in logging on as root using Slim, but then it got hung up when I tried my own personal account.

But now it doesn't boot properly at all.

It could very well be the computer itself. I got it second-hand a few years ago and it was in very rough shape. I put in some new parts and I got it to run, though sometimes erratically. In the last while, though, some of the external ports don't seem to work properly, leading me to believe that the machine's days are drawing to a close.

I'll try a fresh installation one more time and if it doesn't work, I'll take it out of service and part it out.
The machine in question appears to have given up the ghost. All attempts to install FreeBSD have failed, partly because it won't read the disks any more.

On the other hand, I have 2 newer machines which I was able to upgrade to version 11 and are running properly now. It would appear, then, that the age of the computer I worked on earlier was the reason why I had the problems I reported.