Mac Mini 2012 USB 3.0 mount error

Hi everyone,

I can't boot FreeBSD 11.0 (RELEASE, amd64) on my Mac Mini 6,2 (late 2012). I used FreeBSD-11.0-RELEASE-amd64-memstick.img and wrote it to a USB 2.0 4GB stick, and attempted to boot from it, but the default boot sequence returns the following error:
mountroot: waiting for device /dev/ufs/FreeBSD_Install...
Mounting from ufs:/dev/ufs/FreeBSD_Install failed with error 19.
I tried to mount all of the listed valid disk boot devices at the mountroot> prompt without success. I also tried the following at the loader prompt without success:
I understand that others have solved this issue by moving the USB stick to a USB 2.0 port, but there are no USB 2.0 ports on this Mac Mini - only four USB 3.0 ports. Obviously, there's no way to access the UEFI/BIOS on this Mac to disable xHCI/USB 3.0 (to drop the ports to USB 2.0 mode). Attempting to boot 10.3 and 12.0 results in the same errors. I don't have a CD/DVD drive available.

Any ideas?
If all you want to do is run installer, then I suggest to use mfsbsd which is simply the normal install but packaged into memoryfs that will be loaded before kernel starts. I've used Special Edition for this situation (no CD and no bootable USB).
After boot login as root and run bsdinstall
Thanks aribi.

It looks like I didn't have to go the route of mfsbsd. All I needed to do was to boot the mac & hold down the Option/Alt key, and then plugin in the USB drive after the bootloader appears. The EFI drive appears and I can successfully boot FreeBSD all the way after that.

The original problem happened because the USB drive was plugged in before I even started the Mac.