login.conf defaults to russian and it takes effects

jronald

Active Member

Reaction score: 9
Messages: 176

/etc/login.conf
Code:
#
# Russian Users Accounts. Setup proper environment variables.
#
russian|Russian Users Accounts:\
:charset=UTF-8:\
:lang=ru_RU.UTF-8:\
:tc=default:
Some applications display in Russian by default, for example: ibus config dialog, vlc.
I commented the lines above and reboot, the applications still displays in Russian.
How to let the applications display in English?
Thanks
 

getopt

Aspiring Daemon

Reaction score: 376
Messages: 638

You most probably have edited the file not having taken care of a proper closing of a section above the Russian section. Termination of a section is a colon at the end of a line (not ending with a backslash).
 
OP
OP
jronald

jronald

Active Member

Reaction score: 9
Messages: 176

You most probably have edited the file not having taken care of a proper closing of a section above the Russian section. Termination of a section is a colon at the end of a line (not ending with a backslash).
This is original.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,565
Messages: 30,285

This is not the default, it's an example. It's not even active until you add the class to a user.

Some applications display in Russian by default, for example: ibus config dialog, vlc.
That's probably your own locale(8) settings. Or you added your user to the aforementioned class. Either way, the class exists but doesn't do anything until you assign it somewhere.
 
OP
OP
jronald

jronald

Active Member

Reaction score: 9
Messages: 176

Yes, I installed FreeBSD 12 in another computer, the applications display in English instead of Russian.
I'll check, thanks.
 
Top