linux-opera von FreeBSD 11.4

hruodr

Aspiring Daemon

Reaction score: 205
Messages: 772

Does someone have it working?

After installing, I get opera without up to date certificates. When I start Opera, I begins
to connect everywhere and to open an infinite number of windows asking to accept or
reject the expired certificate.

If I manage, with much effort, to cloes the windows and try to import the certificate in
/usr/local/etc/ssl/cert.pem, then it fails to import it:

The certificate installation failed.
 
OP
H

hruodr

Aspiring Daemon

Reaction score: 205
Messages: 772

Now I installed it as authorities. I was doing it as personal, my error. I get a different error:

The server's certificate chain is incomplete, and the signer(s) are not registered. Accept?
 
OP
H

hruodr

Aspiring Daemon

Reaction score: 205
Messages: 772

Well, it is not a new version of opera:
# linux-opera --version
Opera 12.16 Build 1860 for Linux i386.
# opera --version
Opera 12.16 Build 1860 for FreeBSD x86_64.
 

scottro

Daemon

Reaction score: 736
Messages: 1,835

The best way to start is probably with a quick email to the port maintainer, mentioning that it's old. I haven't used opera in a long time, so don't know their current versions. I see (using pkg search opera) that the non-Linux opera is also around 12.16 for the non Linux version.
If the email to the port maintainer doesn't get an answer, then you ca try filing a RFE (request for enhancement) at https://bugs.freebsd.org/bugzilla/enter_bug.cgi
 

Phishfry

Beastie's Twin

Reaction score: 2,333
Messages: 5,261

Opera has failed as a browser. Use at your own risk. This version in ports is the last of the old Opera.
 
OP
H

hruodr

Aspiring Daemon

Reaction score: 205
Messages: 772

I just wanted a browser with addblocker. I did not want to put addons on my firefox, I do not trust them.
There is a portal whose service I need, but the lot of adds lame firefox and chrome.

Perhaps I could run a full linux distribution in a jail or with bhyve, and then install any browser? I do not
have much experience with emulation and also do not like it.
 
Top