• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved /lib/libz.so.6: version ZLIB_1.2.9 required by /usr/local/lib/libpng16.so.16 not found

Jason_25

Member

Thanks: 1
Messages: 57

#1
KDE installed from packages cannot start on a clean installation of FreeBSD 11. The message "can not start kdeinit4 appears" and the above error appears on the console log.

Fixes to salvage the installation:
1.Specify LD_PRELOAD=/usr/lib32/libz.so.6 in startkde4, before calling startx, in xinitrc, in .xsessionrc have all failed and the original file at /lib/libz.so.6 is still being referenced
2. Recompiling the png port and reinstalling results in - libkdecore.so.5 undefined symbol fdatasync
3. Overwriting /lib/libz.so.6 with /usr/lib32/libz.so.6 wrecks the system

I was hoping to keep to using the packages and not have to recompile everything. Are there any other fixes here other than giving up on the package system? This is a clean install so I don't understand why I am having so much trouble.

edit:
I just needed to upgrade to 11.1. The packages were compiled against that version. You would think I would have figured to do this already but I hate upgrading.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,998
Messages: 26,762

#2
From 11.0 onward only the latest minor version is supported. Support for 11.0 ended at 30 November 2017 (around three months after the release of 11.1). Support for 11.1 will end around three months after the the release of 11.2.
 
Top