Lenovo T420s with GPT

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

Hi guys,

An older question I was meaning to ask again is if any of you are experiencing this behavior: Lenovo T420s with Intel 160GB SSD, cannot boot from it with GPT partitions (the laptop cannot detect any booting blocks on the hdd). I also tried with a normal WS Scorpio Black disk but got the same behavior. If I use normal labels, it works/boots but not with GPT.

In BIOS, I tried setting UEFI and Legacy boot but it made no difference.

Any other ideas ?
 
OP
OP
D

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

UPDATE: Tried a BIOS upgrade and setting the HDD mode between AHCI and Legacy mode but got the same result.

LE: I think this thread would be more suited under the hardware section. Sorry for the mistake. @DD, is it possible to move it m8 ? :)
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

The PMBR part of a GPT should make booting possible. Unless it's possible to install without it. Check it by running a live CD and using fdisk(8) or equivalent. The PMBR shows as one big whole-disk partition with type 0xee.
Code:
The data for partition 1 is:
sysid 238 (0xee),(EFI GPT)
If it shows that, then the fault is with the T420. IBM did silly stuff with disk partitions back in the old days, and Lenovo may have carried on with that tradition. If it's looking for a special partition layout, well--there's just no pleasant way to say this--you may have to contact Lenovo tech support.
 
OP
OP
D

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

If the latter is the case, irony is at it's peak here, considering I was working for the big blue up until 2 months ago.
Thx for the hint, will have a look at it.
 
OP
OP
D

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

Finally got the new SSD I was waiting for (the old one broke down after 2 months - no idea how that happened) and I installed a 8.1 amd64 on it, but the disk is in my workstation (8 core i7 with 6GB Patriot RAM - building world to the latest 8-STABLE). I have a RooTonZFS and I confirm that the partition is of type 0xee.

Will post a bit later if it boots in my laptop.
 
OP
OP
D

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

So .. it's official, Lenovo T420s cannot boot from GPT (crap).
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

What does gpart show say about the drive and partitions?
 
OP
OP
D

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

The normal stuff:
Code:
=>       34  312581741  ada0  GPT  (149G)
         34        128     1  freebsd-boot  (64K)
        162    2097152     2  freebsd-swap  (1.0G)
    2097314  310484461     3  freebsd-zfs  (148G)
 

chmiels

New Member

Reaction score: 2
Messages: 19

That's strange. I have L420 with Kingston's SSD, partitioned by myself and no problems occur with gptzfsboot. Partitions were created using gptfdisk (description found on Arch Linux wiki) and later using gpart.
 
OP
OP
D

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

Well, mine doesn't want to boot from an SSD or normal platter disk.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

Last idea: is the bootcode installed?
# gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ada0
 
OP
OP
D

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

Yes it is and I have also manually re-written the bootcode again but with no success.
 
OP
OP
D

da1

Aspiring Daemon

Reaction score: 95
Messages: 876

Either there's a problem with my laptop or with the entire T420s line. I will try talking to those windows-centric warranty guys but I highly doubt they will do anything not "next-next-next-finish" related.
 
Top