Solved Leapseconds file expired

free-and-bsd

Aspiring Daemon

Reaction score: 145
Messages: 925

Well, I don't know about the way it's supposed to work... but my system doesn't seem to update any leap-seconds files. And the fetch command, when run manually, seems to accomplish nothing:
Dec 13 09:18:01 notebook2 ntpd[695]: leapsecond file ('/etc/ntp/leap-seconds'): expired less than 351 days ago
 

tingo

Son of Beastie

Reaction score: 628
Messages: 2,526

Have you updated the certificate port, as described earlier in this thread?
 

free-and-bsd

Aspiring Daemon

Reaction score: 145
Messages: 925

No, waiting for the major upgrade to 12.0 !!! No time for that yet. :)
OK, updated everything now to FreeBSD-12.0-p7. Still didn't work until I added the following to my /etc/rc.conf (according to /etc/defautls/rc.conf):
Code:
ntp_leapfile_sources="https://www.ietf.org/timezones/data/leap-seconds.list"
ntp_leapfile_fetch_opts="-mq"
ntp_leapfile_expiry_days=30
ntp_leapfile_fetch_verbose="YES"
 

mariusvw

New Member

Reaction score: 1
Messages: 10

A client ran into the following error while the machine was correctly functioning.

Code:
freebsd nptd[12345]: leapsecond file ('/var/db/ntpd.leap-seconds.list'): expired 122 days ago

At first we tried fixing this with:

service ntpd onefetch

After checking further we noticed the client removed the package ca_root_nss.

pkg install ca_root_nss && service ntpd onefetch

Still ran into an error which seemed that the DNS resolving failed. Our client removed the nameserver from /etc/resolv.conf too.
After resolving this running the onefetch again fixed all issues.
 

getopt

Aspiring Daemon

Reaction score: 616
Messages: 866

A client ran into the following error
Dear Marius,

as client's stupidities know no limits, please spare us with stories like that.

The FreeBSD forums is not meant to document all kind of failures and possibilities in the real world. A lot of people read postings here and do not want to lavish their lifetime of problems any newbie could solve.

Instead use this forum when YOU need help. Please!

For client-fun-storied we have the Off-Topic-Forum, where things go like "client got strangulated with wireless mouse cable".

Disclaimer: Not meant to be personally offensive.
 
Top