UFS Large file process slows disk access

semi-ambivalent

Active Member

Reaction score: 3
Messages: 125

I'm running a 10.2 machine. Works fine, pretty responsive. However, if I'm doing a large file manipulation (not just, but especially pg_dump(1)), disk access for other things pretty much stops. I've played around with scheduler choice and preemption and they seem to be no silver bullet. I have set
sysctl vfs.read_max=256 on this 8GB machine.

Other than nice-ing things is there a setting I can monkey with here?

Thanks,
s-a
 
Last edited by a moderator:

Crest

Active Member

Reaction score: 63
Messages: 211

Insert a GEOM scheduler instance between the disk providers and their consumers. The GEOM scheduler stores no metadata on devices so you have to insert the scheduler instances yourself in /etc/rc.local:
sysctl -n kern.disks | xargs -n 1 gsched insert
 
Last edited by a moderator:
Top